This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 558569 - the Samba Share "Resource Name:" parameter not being used anywhere
the Samba Share "Resource Name:" parameter not being used anywhere
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.4
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
John Sefler
: SubBug
Depends On:
Blocks: RHQ_Config
  Show dependency treegraph
 
Reported: 2010-01-25 12:29 EST by John Sefler
Modified: 2014-05-23 17:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-23 17:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2010-01-25 12:29:14 EST
Description of problem:
When creating a Samba Share child resource within the iManage UI, there are two paramters whose usage is confusing:
1. Resource Name:
2. Name

The "Name" parameter is used to actually name the share.  It gets written to the smb.conf file as the share name.  It is used as the Resource Key for the child resource.  And it is appended by the string " share" to identify the share as a child resource of the Samba Server.

So the problem is:
Where does the "Resource Name:" value get used?  It looks like nowhere.

Expected results:
Personally I believe the intended design was for the "Resource Name:" value was to be used to name the child resource in the UI.  Therefore the hard-coded appending of " share" to the Name value is a bug.  The samba shares (child resources) of a samba server should be presented in the UI by the "Resource Name:" values entered at creation time.
Comment 1 wes hayutin 2010-02-16 11:53:58 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 11:59:16 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Corey Welton 2010-09-30 10:09:12 EDT
lowering severity/priority - not an enterprise plugin

Note You need to log in before you can comment on or make changes to this bug.