Bug 55857 - Graphical install allows space in lilo label
Summary: Graphical install allows space in lilo label
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 20:41 UTC by Eric Sandeen
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 17:27:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Sandeen 2001-11-07 20:41:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13SGI_XFS_PR1 i686)

Description of problem:
Grub allows spaces in boot labels, lilo doesn't .  Anaconda allows them in
both, which will cause a failure.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run graphical installation
2. Choose lilo for the bootloader
3. Enter a boot label with spaces

	

Actual Results:  Lilo will fail

Expected Results:  I'd expect anaconda to restrict me to valid boot labels
so that lilo will not fail.  ;-)

Additional info:

Works for me - 

--- anaconda-7.2/iw/bootloader_gui.py.orig	Wed Nov  7 14:30:09 2001
+++ anaconda-7.2/iw/bootloader_gui.py	Wed Nov  7 14:30:48 2001
@@ -179,7 +179,7 @@
             cur = text[i]
 # lilo did not allow ' '!, grub does
 #            if cur == ' ' or cur == '#' or cur == '$' or cur == '=':
-            if cur == '#' or cur == '$' or cur == '=':
+            if cur == '#' or cur == '$' or cur == '=' or
(self.lilo_radio.get_active() and cur == " "):
                 entry.emit_stop_by_name ("insert_text")
                 return
             i = i + 1

Comment 1 Brent Fox 2001-11-08 17:21:08 UTC
Yes, I've verified this problem.

Comment 2 Eric Sandeen 2001-11-08 17:27:27 UTC
To be a bit more specific... the text installer handles this properly.

Comment 3 Brent Fox 2001-11-09 04:38:11 UTC
Fixed in cvs on anaconda-7-2-branch and on head.  Thanks for your bug report.


Note You need to log in before you can comment on or make changes to this bug.