Bug 558581 - No confirmation message after saving group configuration change
Summary: No confirmation message after saving group configuration change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Configuration
Version: 1.3.1
Hardware: All
OS: All
low
medium vote
Target Milestone: ---
: ---
Assignee: Charles Crouch
QA Contact: Jeff Weiss
URL:
Whiteboard:
Depends On:
Blocks: rhq4
TreeView+ depends on / blocked
 
Reported: 2010-01-25 18:14 UTC by Jeff Weiss
Modified: 2015-02-01 23:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-03 17:02:03 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2010-01-25 18:14:17 UTC
Description of problem:
After saving a group-config change, there used to be a confirmation message.  That message is no longer there - a regression.

Version-Release number of selected component (if applicable):
2.3.1 (qa build 1)

How reproducible:
always

Steps to Reproduce:
1. create compat group (I used datasources)
2. go to config tab of that group
3. Edit the config, change something, click Save

  
Actual results:
You are taken to the History subtab

Expected results:
You are taken to the history subtab, with a green bar confirmation message that says something about the change being submitted.

Additional info:

Comment 1 Jeff Weiss 2010-02-05 20:05:11 UTC
Turns out this wasn't a regression - there never was a confirmation message.  However there *are* confirm messages when you save a config change for a individual resource.  So I think we should still fix this so it's consistent.

Comment 2 wes hayutin 2010-02-16 16:59:17 UTC
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug

Comment 3 wes hayutin 2010-02-16 17:04:13 UTC
making sure we're not missing any bugs in rhq_triage

Comment 4 Ian Springer 2011-02-16 19:21:39 UTC
We should make sure there are success messages displayed for both resource and group configs in coregui.

Comment 5 John Mazzitelli 2011-03-22 19:25:43 UTC
I just tested this on master and this is working now. You get green messages when you group-change plugin config or resource config.

Comment 6 Sunil Kondkar 2011-06-07 10:27:49 UTC
Verified on build#116 (Version: 4.1.0-SNAPSHOT Build Number: 6ae3b13)

Created a compatible group of datasources, navigated to the config tab and saved a configuration change.
Verified that it navigates to the history page and displays a green message 'The group configuration updates have been initiated'.

Also verified that saving the config change for individual resources navigates to the history page and displays green message (Ex: Configuration updated - current version is 10691).

Marking as verified.

Comment 8 Heiko W. Rupp 2013-09-03 17:02:03 UTC
Bulk closing of old issues that are in VERIFIED state.


Note You need to log in before you can comment on or make changes to this bug.