Bug 558593 - Libguestfs and multilib are incompatible
Libguestfs and multilib are incompatible
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-25 13:43 EST by Richard W.M. Jones
Modified: 2010-03-16 13:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 11:24:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-01-25 13:43:51 EST
This is a placeholder for solving this problem:

 cp: cannot stat `/usr/lib64/guestfs/initramfs.epel-5.i686.supermin.img': No such file or directory

which occurs when libguestfs.i386 and libguestfs.x86_64 are installed
together and stupid multilib picks the wrong one.

See also:
http://rwmj.wordpress.com/2009/11/16/please-someone-shoot-multilib/#content
Comment 1 Richard W.M. Jones 2010-01-25 13:44:12 EST
*** Bug 558463 has been marked as a duplicate of this bug. ***
Comment 2 Richard W.M. Jones 2010-01-26 05:55:52 EST
Patch posted upstream:

http://www.redhat.com/archives/libguestfs/2010-January/msg00029.html
Comment 3 Richard W.M. Jones 2010-01-27 11:24:01 EST
Push upstream:

http://git.annexia.org/?p=libguestfs.git;a=commitdiff;h=214babb060d9e85e72bad4633310a9b4a5fcb9dd

This change will be in libguestfs 1.0.82.

Note You need to log in before you can comment on or make changes to this bug.