Bug 558671 - [abrt] crash in python-bugzilla-0.5.1-3.fc12
[abrt] crash in python-bugzilla-0.5.1-3.fc12
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:c67713d8
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-25 18:50 EST by Jan Hutař
Modified: 2010-03-19 15:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-19 15:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.11 KB, text/plain)
2010-01-25 18:50 EST, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2010-01-25 18:50:02 EST
abrt 1.0.3 detected a crash.

How to reproduce: 1. I was just running this quite big query
Comment: I was just running this quite big query
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/bugzilla query --reporter=jhutar@redhat.com '--outputformat=%{bug_id} --outputformat'
component: python-bugzilla
executable: /usr/bin/bugzilla
kernel: 2.6.31.9-174.fc12.x86_64
package: python-bugzilla-0.5.1-3.fc12
uuid: c67713d8
Comment 1 Jan Hutař 2010-01-25 18:50:06 EST
Created attachment 386730 [details]
File: backtrace
Comment 2 Will Woods 2010-01-26 12:30:24 EST
The bugzilla CLI doesn't handle the socket.error exception cleanly; this is now fixed in git. 

This won't fix the error you encountered, which was errno 110 - socket timeout (i.e. the server stopped responding). But it won't be considered a crash anymore.
Comment 3 Petr Beňas 2010-03-15 07:43:41 EDT

How to reproduce
-----
1. when the bugzilla was down and I tried to login it via python-bugzilla, this crash happened
2. $ bugzilla login
3.
Comment 4 Will Woods 2010-03-19 15:14:20 EDT
This is fixed in python-bugzilla-0.6.0, which will be in Fedora 13. 

Since the crash is purely cosmetic, it probably won't be backported to python-bugzilla-0.5.1 (F11/F12).

Note You need to log in before you can comment on or make changes to this bug.