Bug 55871 - Zip disk is not always 4th partition of device
Zip disk is not always 4th partition of device
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-11-07 18:33 EST by Stephen Cornell
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-07 18:34:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Cornell 2001-11-07 18:34:00 EST
Description of Problem:
Kudzu autodetects an internal Zip drive, and automatically creates a line 
in /etc/fstab that assigns the 4th partition on that device to the mount 
point (as described in the Zip mini-HOWTO).  However, on some hardware 
one needs to specify the whole device, not just the 4th partition

Version-Release number of selected component (if applicable):

How Reproducible:
Every time

Steps to Reproduce:
1. Boot a system that has a Zip drive

Actual Results:
Kudzu creates a line in /etc/fstab of the form
/dev/hdd4   /mnt/zip250.0    auto    noauto,owner,kudzu 0 0

Attempting to mount the zip drive by clicking on the desktop idon or 
`mount /mnt/zip250.0' fails, and gives an error message.
The same result if one tries `mount -t vfat /dev/hdd4 /mnt/zip250.0'

Expected Results:
For my hardware, the line should be 
/dev/hdd  /mnt/zip250.0    auto    noauto,owner,kudzu 0 0

Mounting now works fine, as does
`mount -t vfat /dev/hdd /mnt/zip250.0'

Additional Information:
This only applies to some hardware (indeed, only one of my two machines) 
- I can provide fuller details of my setup if you want.  The fix is 
completely trivial once one knows what to do, but is not documented 
anywhere (not even the Zip mini-HOWTO); I found it by chance on Google at 
after a whole day of frustration.  This needs to be fixed, or at least 
documented somewhere prominent, to save other people the same hassle.
Comment 1 Bill Nottingham 2002-01-24 02:26:20 EST
The kudzu currently in rawhide allows for an /etc/updfstab.conf, where you can
configure things such as the default partition to use for a particular device.
Comment 2 Stephen Cornell 2002-01-24 04:45:27 EST
And how is the user supposed to know which particular partition to use?
How is the user supposed to know that `wrong partition number' is the 
origin of the problems they are having?  The `experts' I consulted on
Usenet were convinced that I had either bad media or a faulty drive.

In my opintion, this bug isn't fixed unless Kudzu recognizes what to use 
automatically.  Have you done an investigation into which hardware 
requires `hdd4' and which requires `hdd' ?  Have you made inquiries 
with Iomega?
Comment 3 Bill Nottingham 2002-01-24 10:20:20 EST
It's not a property of the hardware. It's a property of how the disk itself was
Comment 4 Stephen Cornell 2002-01-24 12:34:50 EST
No, it's *not* a property of the disk. It happens with every disk I've tried
(100 or 250).
I have two Red Hat 7.2 machines, both with zip250 drives.  On one of them
I have to mount /dev/hdd, on the other it's /dev/hdb4; if I try /dev/hdd4 on 
the first I get:

mount: wrong fs type, bad option, bad superblock on /dev/hdd4,
       or too many mounted file systems

and similarly if I try to mount the *same disk* as /dev/hdb on the other.

Do I take it you haven't reproduced the bug?

Note You need to log in before you can comment on or make changes to this bug.