Bug 558774 - Win2k3 guests last long time during hibernating with ide block in large host
Win2k3 guests last long time during hibernating with ide block in large host
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-26 06:51 EST by Qunfang Zhang
Modified: 2013-12-08 19:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 04:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kvm_stat (1.34 KB, application/octet-stream)
2010-01-26 06:53 EST, Qunfang Zhang
no flags Details
sar -R -r 1 100 (7.77 KB, application/octet-stream)
2010-01-26 06:54 EST, Qunfang Zhang
no flags Details
strace -p pid_of_qemu (600.20 KB, application/octet-stream)
2010-01-26 06:54 EST, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2010-01-26 06:51:55 EST
Description of problem:
Win2k3 guest last long time during hibernating with ide block in large host(96 cpu and 1000G mem).

              ide block       virtio block
win2k3-32     15 minutes        1 minutes
win2k3-64     25 minutes        2 minutes

I test it in small host(4 vpu and 4G mem), it works well. Guest can hibernate and resume quickly.

The command line I used:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -m 2G -smp 2 -drive file=/opt/win2k3-32-virtio-virtio.raw,media=disk,if=ide,index=0 -net nic,vlan=0,macaddr=10:1a:4a:10:20:5f,model=rtl8139 -net tap,vlan=0,script=/etc/qemu-ifup -uuid `uuidgen` -cpu qemu64,+sse2 -notify all -vnc :2 -monitor stdio -boot c

Version-Release number of selected component (if applicable):
kvm-83-150.el5
kernel: 2.6.18-185.el5

How reproducible:
Always

Steps to Reproduce:
1.boot a win2k3 guest using ide block with the above command line.
2.enable hibernate inside guest by: input #powercfg -h on in command prompt.
3.hibernate the guest by: click "start" menu -> shutdown -> hibernate
  
Actual results:
It takes about 25 min for win2k3-64 guest and 15 min for win2k3-32 guest during hibernate with ide block.
I test with the same guest image and command line using virtio block, it takes only 1 or 2 min to hibernate.

Expected results:
Guest can hibernate and resume within a short time.

Additional info:
host info:
[root@intel-XE7450-512-1 ~]# free
             total       used       free     shared    buffers     cached
Mem:    1054284312    2156316 1052127996          0      39300    1532688
-/+ buffers/cache:     584328 1053699984
Swap:    138903544          0  138903544


[root@intel-XE7450-512-1 ~]# cat /proc/cpuinfo (96 cpu, here only list one.)

processor	: 95
vendor_id	: GenuineIntel
cpu family	: 6
model		: 29
model name	: Intel(R) Xeon(R) CPU           E7450  @ 2.40GHz
stepping	: 1
cpu MHz		: 2398.892
cache size	: 12288 KB
physical id	: 15
siblings	: 6
core id		: 5
cpu cores	: 6
apicid		: 125
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm
bogomips	: 4798.63
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:
Comment 1 Qunfang Zhang 2010-01-26 06:53:23 EST
Created attachment 386806 [details]
kvm_stat
Comment 2 Qunfang Zhang 2010-01-26 06:54:19 EST
Created attachment 386807 [details]
sar -R -r 1 100

sar -R -r 1 100 during long time hibernate
Comment 3 Qunfang Zhang 2010-01-26 06:54:59 EST
Created attachment 386808 [details]
strace -p pid_of_qemu

strace -p pid_of_qemu during long time hibernate
Comment 4 Qunfang Zhang 2010-01-27 03:43:06 EST
Re-test this case with win2k8-64 guest. This issue also exists. 

And, if install the win2k8-64 guest with ide block, then boot it with ide block too, it takes a few seconds to hibernate.
BUT, if install the win2k8-64 guest with virtio block,then boot it with ide block. it will take 10 minutes to hibernate.
Comment 5 Gleb Natapov 2010-05-17 08:27:37 EDT
(In reply to comment #4)
> Re-test this case with win2k8-64 guest. This issue also exists. 
> 
> And, if install the win2k8-64 guest with ide block, then boot it with ide block
> too, it takes a few seconds to hibernate.
> BUT, if install the win2k8-64 guest with virtio block,then boot it with ide
> block. it will take 10 minutes to hibernate.    

Looks like Windows issue to me. Can you retest this one more time? Also can you check that if you instal win2k3 with ide it hibernates fast with ide?
Comment 6 Qunfang Zhang 2010-05-18 02:43:28 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Re-test this case with win2k8-64 guest. This issue also exists. 
> > 
> > And, if install the win2k8-64 guest with ide block, then boot it with ide block
> > too, it takes a few seconds to hibernate.
> > BUT, if install the win2k8-64 guest with virtio block,then boot it with ide
> > block. it will take 10 minutes to hibernate.    
> 
> Looks like Windows issue to me. Can you retest this one more time? Also can you
> check that if you instal win2k3 with ide it hibernates fast with ide?    

I re-test win2k3-64 and win2k8-64 in the same large host, on the latest kvm version(the version in bug description is too old).
kvm: kvm-83-181.el5
kernel:2.6.18-194.el5

But , can not reproduce it any more.

I installed win2k3 and win2k8-84 guest with virtio block, and then did the following hibernate test:
              if=ide      if=virtio
win2k3-64:     OK           OK
win2k8-64      OK           OK

So this issue does not exsit in the latest rhle5.6 kvm version but don't know why.
Comment 7 Gleb Natapov 2010-05-18 04:01:19 EDT
Closing for now then.

Note You need to log in before you can comment on or make changes to this bug.