Bug 55880 - network stop doesn't stop ciped-cb
network stop doesn't stop ciped-cb
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 03:17 EST by Ulrich Drepper
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 03:17:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2001-11-08 03:17:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+)
Gecko/20011106

Description of problem:
If there is a configuration file ifcfg-cipcb0 the /etc/init.d/network
script correctly uses it to bring up the interface.  But network stop
doesn't kill the CIPE daemon.  The reason is the way the 'interfaces'
variables is computed.  It explicitly excludes cipcb*.  This is OK for
start since CIPE interfaces are handled special.  But there is no such
code for stop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create ifcfg-cipcb0 (plus other files CIPE needs)
2.run /etc/init.d/network start
3.run /etc/init.d/network.stop
4.run /etc/init.d/network start
	

Actual Results:  After the fourth step above an error is signalled
telling us that ciped-cb is still running.

Expected Results:  network stop should kill ciped-cb.

Additional info:
Comment 1 Bill Nottingham 2002-01-25 00:39:18 EST
This should be fixed in 6.50-1.

Note You need to log in before you can comment on or make changes to this bug.