Bug 55885 - named exits after waking up from suspend mode
named exits after waking up from suspend mode
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 06:16 EST by Karsten Weiss
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 07:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Weiss 2001-11-08 06:16:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
named exits when the system is waking up from suspend mode because of the
following internal assertion failure:

Nov  8 11:21:55 addx network: Netzwerkparameter einstellen:  succeeded
Nov  8 11:21:56 addx named[792]: ifiter_ioctl.c:214: REQUIRE(iter->pos <
(unsigned int) iter->ifc.ifc_len) failed
Nov  8 11:21:56 addx named[792]: exiting (due to assertion failure)
Nov  8 11:21:57 addx network: Interface lo starten:  succeeded

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.suspend the machine
2.wakup
3.service named status
	

Actual Results:  named isn't running anymore

Expected Results:  a running named

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-09 07:16:43 EST
This is almost certainly because all your network interfaces get restarted 
(and bind isn't wrong in doing this if you pull away all interfaces it's 
listening on).

I think the best way to fix this is to add a list of services that need 
restarting in apmd.
Comment 2 Bernhard Rosenkraenzer 2001-11-09 08:32:25 EST
RESTORESERVICES option added (and defaulting to named) in apmd-3.0final-35.


Note You need to log in before you can comment on or make changes to this bug.