Bug 558875 - no valid sudoers sources found
no valid sudoers sources found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-01-26 11:22 EST by Arthur Clement
Modified: 2010-04-23 15:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 15:45:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add placeholder README to /etc/sudoers.d (1.18 KB, patch)
2010-02-15 17:59 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Arthur Clement 2010-01-26 11:22:51 EST
Description of problem:
#sudo                                                                             sudo: parse error in /etc/sudoers near line 96
sudo: no valid sudoers sources found, quitting


Version-Release number of selected component (if applicable):
1.7.2p2-2.fc13 



I had to remove all comments after "root    ALL=(ALL)       ALL" to make it work.
Comment 1 Ville Skyttä 2010-02-15 17:59:05 EST
This appears to be because of the newly added #includedir directive.  It looks like sudo barfs if the included dir is empty which I failed to test when suggesting adding this feature, sorry about that.

IMO this sounds like a upstream bug; I don't think an empty included dir should be a problem.  Apart from getting a real fix for that, one way to work around it would be to add let's say a /etc/sudoers.d/README containing valid sudoers format comments, something like the attached patch (README is intentionally a non-%config file even though rpmlint complains about it).
Comment 2 Ville Skyttä 2010-02-15 17:59:41 EST
Created attachment 394420 [details]
Add placeholder README to /etc/sudoers.d
Comment 3 Daniel Kopeček 2010-02-15 18:53:26 EST
From the ChangeLog:

Major changes between version 1.7.2p1 and 1.7.2p2:
    ...
    * No longer produce a parse error when #includedir references a directory that contains no valid filenames.
    ...

Seems to be a regression. I'm going to investigate this and hopefully do a new build tomorrow.
Comment 4 Daniel Kopeček 2010-02-16 16:45:04 EST
Ok, it's not a regression... the fix didn't made it to the release tarball (don't know why). Here are the cvs commits:

toke.c:
http://www.sudo.ws/cgi-bin/cvsweb/sudo/toke.c.diff?r1=1.37&r2=1.38&f=h

toke.l:
http://www.sudo.ws/cgi-bin/cvsweb/sudo/toke.l.diff?r1=1.38&r2=1.39&f=h

the toke.l part is present in the 1.7.2p2 tarball but the toke.c part is not. So I guest it's a mistake. Reported upstream and a new build for rawhide is on the way.
Comment 5 Daniel Kopeček 2010-02-16 17:37:21 EST
New build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1992154
Comment 6 Adam Williamson 2010-04-23 15:45:41 EDT
Discussed at today's blocker review meeting. Two of us confirmed that current F13 sudo, sudo-1.7.2p6-1.fc13.x86_64 , seems to behave fine. We're closing this; please re-open if we're missing something. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.