Bug 55910 - [3c59x] Network problem: ~4 hrs post boot 3c905 NIC disabled permanently by APM on Compaq Deskpro
[3c59x] Network problem: ~4 hrs post boot 3c905 NIC disabled permanently by A...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 11:48 EST by Normand Robert
Modified: 2013-07-02 22:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 18:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Normand Robert 2001-11-08 11:48:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
Every 4-8 hours ethernet connectivity is lost and never spontaneously
recovers afterwards. Transmit errors appear in /var/log/messages

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot up
2.Wait 4-8 hours and tranmit errors appear
3. Reboot required
	

Actual Results:  Ethernet connectivity lost. Excerpt from /var/log/message
showing problem. Message below repeat with  changing "Status register
values"
Full log available on request.

Nov  8 04:09:24 norm su(pam_unix)[27362]: session closed for user news
Nov  8 04:47:35 norm sysctl: net.ipv4.ip_forward = 0
Nov  8 04:47:35 norm sysctl: net.ipv4.conf.default.rp_filter = 1
Nov  8 04:47:35 norm sysctl: kernel.sysrq = 0
Nov  8 04:47:35 norm network: Setting network parameters:  succeeded
Nov  8 04:47:36 norm network: Bringing up interface lo:  succeeded
Nov  8 04:47:36 norm kernel: PCI: Found IRQ 11 for device 00:0d.0
Nov  8 04:47:36 norm kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Nov  8 04:47:36 norm kernel: 00:0d.0: 3Com PCI 3c905 Boomerang 100baseTx at
0x1040. Vers LK1.1.16
Nov  8 04:47:36 norm kernel: eth0: Transmit error, Tx status register d0.
Nov  8 04:47:36 norm kernel:   Flags; bus-master 1, dirty 1(1) current 1(1)
Nov  8 04:47:36 norm kernel:   Transmit list 00000000 vs. c61a9240.
Nov  8 04:47:36 norm kernel:   0: @c61a9200  length 8000002a status
8000002a
Nov  8 04:47:36 norm kernel:   1: @c61a9240  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   2: @c61a9280  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   3: @c61a92c0  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   4: @c61a9300  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   5: @c61a9340  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   6: @c61a9380  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   7: @c61a93c0  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   8: @c61a9400  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   9: @c61a9440  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   10: @c61a9480  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   11: @c61a94c0  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   12: @c61a9500  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   13: @c61a9540  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   14: @c61a9580  length 00000000 status
00000000
Nov  8 04:47:36 norm kernel:   15: @c61a95c0  length 00000000 status
00000000
Nov  8 04:47:38 norm network: Bringing up interface eth0:  succeeded
Nov  8 04:47:39 norm kernel: eth0: Host error, FIFO diagnostic register
2000.
Nov  8 04:47:39 norm kernel: eth0: PCI bus error, bus status 00a00021
Nov  8 04:47:40 norm kernel: eth0: Transmit error, Tx status register d0.
Nov  8 04:47:40 norm kernel:   Flags; bus-master 1, dirty 1(1) current 1(1)
Nov  8 04:47:40 norm kernel:   Transmit list 00000000 vs. c61a9240.
Nov  8 04:47:40 norm kernel:   0: @c61a9200  length 8000002a status
8000002a
Nov  8 04:47:40 norm kernel:   1: @c61a9240  length 8000002a status
0000002a
Nov  8 04:47:40 norm kernel:   2: @c61a9280  length 8000002a status
0000002a
Nov  8 04:47:40 norm kernel:   3: @c61a92c0  length 8000002a status
8000002a
Nov  8 04:47:40 norm kernel:   4: @c61a9300  length 00000000 status
00000000
Nov  8 04:47:40 norm kernel:   5: @c61a9340  length 00000000 status
00000000
Nov  8 04:47:40 norm kernel:   6: @c61a9380  length 00000000 status
00000000




Additional info:

Connectivity maintained just like my RH6.0 installation which had been up
for 30days before installation of RH 7.2 RH 7.2 was installed on a separate
partition so RH 6 boot still possible via boot floppy.
Comment 1 Normand Robert 2001-11-08 12:49:20 EST
Clarifications.

System is a Compaq DeskPro.
System ran RH6.1 for months without reboots until last week when RH 7.2 was
added.
Problem occurs when booting in RH7.2 and has occured consistently following
first and second installation of RH7.2
System was not upgraded. RH7.2 was installed on a 2nd HD. RH6.1 still
available for boot via floppy.
Comment 2 Admin @ Brittany Software 2001-11-08 20:17:40 EST
I had a similar problem after updating from 6.x to 7.2. The system had two 
3c59x based cards and one of the cards was not working after a while.

When swapping the two cards, the other interface was shutting down after a 
while. I decided to change the card instead of investigating the problem 
further as I needed to get the machine back up right away.

You may want to see if the apm service is running as it was also showing up in 
the log at about the same time and I believe it may be the cause of the 
problem, restarting the network services.
Comment 3 Normand Robert 2001-11-09 17:10:45 EST
Workaround:

The problem can be fixed by shutting down Advanced Power Management (APM). 

There may be a better workaround than this involving setting  

NET_RESTART="no"
NETFS_RESTART="no"

in /etc/sysconfig/apmd to prevent only the network from being shut down but I
have not yet tried this.


Comment 4 ronny.lampert 2002-05-29 09:56:45 EDT
I have the same problem on a standard-non-apm-system with the stock RH-Kernel
(2.4.7) - after a while, the 3c905 ("Votex/Boomerang/Tornado et. al") simply
drops the link.
I've had this problem also on a 2.4.17 custom compiled.
Seems that my custom 2.4.18 works fine with those cards.
Comment 5 Jeff Garzik 2002-10-25 15:35:46 EDT
Can this be verified as fixed in the current 8.0, or stock kernel.org 3c59x driver?
Comment 6 Jeff Garzik 2003-01-18 18:58:43 EST
No response after multiple months, I'm going to close this bug.

Please file a new bug if this continues to occur in 8.0 release, 8.1 beta, or
the latest errata kernel for 7.0/7.1/7.2.

Note You need to log in before you can comment on or make changes to this bug.