Bug 559107 - "Num Lock" key act as "Backspace" key in qemu monitor
"Num Lock" key act as "Backspace" key in qemu monitor
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-27 02:18 EST by Miya Chen
Modified: 2013-01-09 17:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 14:54:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miya Chen 2010-01-27 02:18:47 EST
Description of problem:
"Num Lock" key act as "Backspace" in qemu monitor 


Version-Release number of selected component (if applicable):
kvm-83-152.el5

How reproducible:
100%

Steps to Reproduce:
1.start guest with vnc connection
2.go to qemu monitor by "ctl+alt+2"
3.input "56" in monitor
4.press "Num Lock"

  
Actual results:
the last character is deleted, "Num Lock" key act as "Backspace" in qemu monitor 

Expected results:


Additional info:
Comment 1 Miya Chen 2010-01-27 02:57:47 EST
additional info:
Press Insert key in qemu monitor, got "c" in command line.
Press Caps Lock key in qemu monitor, got Sigma in command line
"ctl+up", "ctl+down", "ctl+pageup", "ctl+pagedown" cannot move page up and down in qemu monitor
Comment 2 Dor Laor 2010-02-09 04:49:50 EST
What's the qemu command line? Did you try to use -K?
Comment 3 Miya Chen 2010-03-15 04:02:10 EDT
(In reply to comment #2)
> What's the qemu command line? Did you try to use -K?    

cmd usd:

#/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -drive file=rhel5.5-32-virtio.qcow2,if=virtio,format=qcow2,cache=off,boot=on -smp 2 -m 1G -vnc :9 -net nic,macaddr=20:20:99:33:11:23,model=e1000,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -balloon none -uuid `uuidgen` -startdate now -k en-us
Comment 5 RHEL Product and Program Management 2011-01-11 15:29:03 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:49:21 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.