Bug 55930 - migrate_all_install.pl error - DUAConfigProfile Error
migrate_all_install.pl error - DUAConfigProfile Error
Status: CLOSED DUPLICATE of bug 55952
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 18:10 EST by Matt
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt 2001-11-08 18:10:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:

Error trying to migrate your login data to LDAP when you select the 
DUAConfigProfile as yes..  I do not see a schema definition for the 
DUAConfigProfile class so I think that is the problem.

[root@gordon migration]# ./migrate_all_online.sh
Enter the X.500 naming context you wish to import into:
[dc=yellowguppy,dc=com]
Enter the name of your LDAP server [ldap]: localhost
Enter the manager DN: [cn=manager,dc=yellowguppy,dc=com]:
Enter the credentials to bind with:
Do you wish to generate a DUAConfigProfile [yes|no]? yes

Importing into dc=yellowguppy,dc=com...

Creating naming context entries...
Creating DUAConfigProfile entry...
Migrating aliases...
Migrating groups...
Migrating hosts...
Migrating networks...
Migrating users...
Migrating protocols...
Migrating rpcs...
Migrating services...
Migrating netgroups...
Migrating netgroups (by user)...
sh: /etc/netgroup: No such file or directory
Migrating netgroups (by host)...
sh: /etc/netgroup: No such file or directory
adding new entry "dc=yellowguppy,dc=com"
ldap_add: Already exists

ldif_record() = 68
Importing into LDAP...
adding new entry "ou=People,dc=yellowguppy,dc=com"

adding new entry "ou=Rpc,dc=yellowguppy,dc=com"

adding new entry "ou=Group,dc=yellowguppy,dc=com"

adding new entry "ou=Networks,dc=yellowguppy,dc=com"

adding new entry "nisMapName=netgroup.byhost,dc=yellowguppy,dc=com"

adding new entry "nisMapName=netgroup.byuser,dc=yellowguppy,dc=com"

adding new entry "ou=Netgroup,dc=yellowguppy,dc=com"

adding new entry "ou=Hosts,dc=yellowguppy,dc=com"

adding new entry "ou=Services,dc=yellowguppy,dc=com"

adding new entry "ou=Mounts,dc=yellowguppy,dc=com"

adding new entry "ou=Aliases,dc=yellowguppy,dc=com"

adding new entry "ou=Protocols,dc=yellowguppy,dc=com"

adding new entry "cn=config,dc=yellowguppy,dc=com"
ldap_add: Undefined attribute type
        additional info: defaultServerList:
                                            C>  B6

ldif_record() = 17
/usr/bin/ldapadd: returned non-zero exit status
[root@gordon migration]#

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run migrate_all_online.pl
2. Enter "yes" for the DUAConfigProfile question
3. Watch it break
	

Actual Results:  Insertion fails..

Expected Results:  Insertion succeed.

Additional info:

[root@gordon redhat]# rpm -qa | grep openldap
openldap-servers-2.0.11-8
openldap-2.0.11-8
openldap-clients-2.0.11-8
openldap-devel-2.0.11-8
[root@gordon redhat]# uname -a
Linux gordon 2.4.9-6 #1 Thu Oct 18 09:22:43 EDT 2001 i586 unknown
[root@gordon redhat]# cat /etc/redhat-release
Red Hat Linux release 7.1 (Seawolf)
[root@gordon redhat]#
Comment 1 Jef Spaleta 2004-02-11 19:44:28 EST

*** This bug has been marked as a duplicate of 55952 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.