Bug 55935 - Sendmail identd timeout causes hangs when connecting to send mail
Sendmail identd timeout causes hangs when connecting to send mail
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 22:11 EST by Mike McHenry
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 22:11:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McHenry 2001-11-08 22:11:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The sendmail.cf config defaults to a 5 second timeout on identd lookups. 
What this means is that anyone connecting to a Redhat mail server and not 
running identd (most Windows clients) will experience a 5 second delay 
while the Redhat box times out on the identd time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Telnet to port 25 on Redhat server running sendmail from a client 
without an identd server (Windows)

Actual Results:  Five second hang will be experienced before getting 
sendmail prompt.

Additional info:

I would recommend changing the default identd timeout in sendmail.cf to 0s 
or something lower than 5 seconds. This can be changed directly in the 
sendmail.mc used to build the cf file...

#O Timeout.ident=5s

should be something like

O Timeout.ident=0s
Comment 1 Florian La Roche 2001-12-08 04:00:43 EST
Why are no rejects done from Windows? Looks like a bad firewall configuration
that could be the cause for this?

I agree that identd is not very useful, but will probably leave the default
settings for now.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.