Bug 55936 - xinetd identd timeouts experienced when using default configurations
Summary: xinetd identd timeouts experienced when using default configurations
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-09 03:18 UTC by Mike McHenry
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 03:18:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McHenry 2001-11-09 03:18:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Most of the files placed in /etc/xinetd.d by various daemons have lines 
like

log_on_failure          += USERID

However, when connecting to any of these daemons from a machine without an 
identd daemon (Windows) you will experience a very long timeout while 
xinetd waits for a response.

This identd lookup is entirely unneccesary for anything useful and should 
not be introduced when 90% of the machines that are likely to connect to 
Redhat servers will not be running identd.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply attempt to connect to a daemon such as imap or pop on a Redhat 
server from a client without an identd daemon.
	

Actual Results:  Long hang while identd times out

Additional info:

I would recommend completely revamping the necessary xinetd.d config files 
to NOT include USERID or somehow make xinetd timeout after a short 
interval (0-5 seconds) when an identd lookup is not available.

There is no good reason for the general case of client connections to 
experience a 30 second timeout because of an unneccesary identd lookup.

Comment 1 Trond Eivind Glomsrxd 2001-11-14 19:42:50 UTC
None of them are in xinetd - file them against the packages with this configuration.


Note You need to log in before you can comment on or make changes to this bug.