Bug 55937 - gcc gives internal error and segmentation fault while compiling kernel
gcc gives internal error and segmentation fault while compiling kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 22:30 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 10:30:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-08 22:30:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
No kernel compile finishes. gcc gives 
Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions. 
at random points during the compile

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download fresh kernel and config it.
2.make dep;
3.make bzImage
	

Actual Results:  eg:
gcc -D__KERNEL__ -I/usr/src/linux-2.4.14/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
-pipe -mpreferred-stack-boundary=2 -march=athlon     -c -o numa.o numa.c
In file included from /usr/src/linux-2.4.14/include/asm/dma.h:13,
                 from /usr/src/linux-2.4.14/include/linux/bootmem.h:8,
                 from numa.c:8:
/usr/src/linux-2.4.14/include/asm/io.h: In function `outw':
/usr/src/linux-2.4.14/include/asm/io.h:319: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [numa.o] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.14/mm'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.14/mm'
make: *** [_dir_mm] Error 2


Expected Results:  gcc should not die like this during intensive compilation

Additional info:

I am appending lspci info
This is a stock redhat 7.2 system with all updates applied

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South]
(rev 22)
00:04.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
00:04.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:04.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
(rev 30)
00:0a.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10000 (rev 08)
00:0b.1 Input device controller: Creative Labs SB Live! (rev 08)
00:0c.0 Multimedia video controller: Brooktree Corporation Bt878 (rev 11)
00:0c.1 Multimedia controller: Brooktree Corporation Bt878 (rev 11)
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20265
(rev 02)01:00.0 VGA compatible controller: nVidia Corporation NV11 (rev a1)
Comment 1 Jakub Jelinek 2001-11-09 10:30:51 EST
If it is at random places, it is not gcc's fault.
By any chance, aren't you running .athlon.rpm kernel? Can you try
.i686.rpm one instead? There are issues with some buggy VIA chipset settings...
Comment 2 Need Real Name 2001-11-11 12:11:19 EST
I tested an i686 kernel and got the same error. I grew suspicious and ran memtest.
Looks like I have a bad RAM stick. Now I can get the kernel to compile on both
686 and athlon kernels.

Note You need to log in before you can comment on or make changes to this bug.