Bug 559370 - RFE: Ability to use non-Redhat channels with default base channel feature
Summary: RFE: Ability to use non-Redhat channels with default base channel feature
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server   
(Show other bugs)
Version: 0.8
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: spacewalk-rfe space18
TreeView+ depends on / blocked
 
Reported: 2010-01-27 21:47 UTC by eric.heydrick
Modified: 2012-11-20 10:31 UTC (History)
4 users (show)

Fixed In Version: spacewalk-utils-1.8.11-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 16:17:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eric.heydrick 2010-01-27 21:47:53 UTC
Description of problem: I would like the ability to use the 'default base channel' feature with non-Redhat supplied channels. This would allow using one activation key for multiple architectures or distributions. Right now I have to assign a different activation key to each base channel architecture.

Comment 1 Jan Pazdziora 2010-11-19 16:02:30 UTC
Mass-moving to space13.

Comment 2 Miroslav Suchý 2011-04-11 07:30:59 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 3 Miroslav Suchý 2011-04-11 07:36:14 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 4 Jan Pazdziora 2011-07-20 11:48:27 UTC
Aligning under space16.

Comment 5 Paul Robert Marino 2012-04-03 18:21:33 UTC
please try the script I attached in this email
https://www.redhat.com/archives/spacewalk-devel/2012-March/msg00085.html
it should work

Comment 6 Michael Mráka 2012-05-04 08:24:52 UTC
spacewalk-common-channel now has ability to create default channel mapping.

E.g.
 spacewalk-common-channel --user admin --password password --default-channels -v 'centos6'

Comment 7 Jan Pazdziora 2012-10-30 19:22:34 UTC
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/

Comment 8 Jan Pazdziora 2012-11-01 16:17:33 UTC
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Comment 9 Jon Nierenburg 2012-11-17 01:09:17 UTC
Trying to create a 'Distribution Channel Map' for CentOS fails because "Releases cannot be less than 3 characters."  

From the GUI (Channels->Distribution Channel Mapping->Create new...) I tried input inputting the following:
Operating System: centos-release
Release: 5
Architecture: x86_64
Channel Label: CentOS 6 - x86_64


I modified Paul Marino's script slightly to use the distchannel.setMapForOrg and I was able to create distributions maps for Centos 5 and 6.

Comment 10 Paul Robert Marino 2012-11-19 17:14:21 UTC
Huh I was about to mark the script as deprecated but if there is still a need I would be happy to update it

Comment 11 Michael Mráka 2012-11-20 10:31:59 UTC
Fixed in spacewalk master by
commit d7771ca94a2db07d84e2379ff52e3fb8af3fb601
    decrease distChannelMap release minimal length
    as e.g. CentOs5 uses '5' by default


Note You need to log in before you can comment on or make changes to this bug.