Bug 5594 - Apparent optimizing bug in egcs
Apparent optimizing bug in egcs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-05 13:17 EDT by guichard
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-07 16:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case and further discussion from reporter (205.36 KB, text/plain)
2000-01-26 12:52 EST, Jim Kingdon
no flags Details

  None (edit)
Description guichard 1999-10-05 13:17:21 EDT
Trying to compile amaya 2.1 I get errors like this:

../../thotlib/unicode/ustring.c: In function `ustrcpy':
../../thotlib/unicode/ustring.c:380: void value not ignored
as it ought to be
../../thotlib/unicode/ustring.c: In function `ustrdup':
../../thotlib/unicode/ustring.c:397: void value not ignored
as it ought to be
../../thotlib/unicode/ustring.c: In function `ustrncpy':
../../thotlib/unicode/ustring.c:481: void value not ignored
as it ought to be

When I compile without -O it works fine. I get this behavior
in egcs-1.1.2-12 on intel and egcs-1.1.2-12 & -13 on sparc,
both with 6.0 (sparc with updated kernel). There is no
problem with gcc-2.7.2.3-11 on my redhat 5.1 machine.
Comment 1 Jim Kingdon 1999-10-05 16:39:59 EDT
Please send the output of gcc -E on the file in question, combined
with the exact command line (e.g "gcc -g -O foo.c") required to
get the error.

Incidentally, I would guess the difference between your two
systems is because of different libraries rather than
gcc2.7 vs. egcs.  But send in the code and I'll have a look.
Comment 2 Jim Kingdon 2000-01-26 12:52:59 EST
Created attachment 79 [details]
Test case and further discussion from reporter
Comment 3 Cristian Gafton 2000-02-07 16:50:59 EST
The glibc headers should fix this in the current rawhide version

Note You need to log in before you can comment on or make changes to this bug.