Bug 559437 - SELinux is preventing /usr/libexec/abrt-hook-python "getattr" access on /.
Summary: SELinux is preventing /usr/libexec/abrt-hook-python "getattr" access on /.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9d9edac7b9c...
: 562440 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-28 04:59 UTC by Lawrence Graves
Modified: 2010-02-24 16:30 UTC (History)
107 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:40:44 UTC


Attachments (Terms of Use)

Description Lawrence Graves 2010-01-28 04:59:49 UTC
Summary:

SELinux is preventing /usr/libexec/abrt-hook-python "getattr" access on /.

Detailed Description:

[abrt-hook-pytho has a permissive type (abrt_helper_t). This access was not
denied.]

SELinux denied access requested by abrt-hook-pytho. It is not expected that this
access is required by abrt-hook-pytho and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:abrt_helper_t:s0-s0:c0.c
                              1023
Target Context                system_u:object_r:fs_t:s0
Target Objects                / [ filesystem ]
Source                        abrt-hook-pytho
Source Path                   /usr/libexec/abrt-hook-python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-python-1.0.4-1.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-73.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.12-174.2.3.fc12.x86_64 #1 SMP Mon Jan 18
                              19:52:07 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 27 Jan 2010 09:56:53 PM MST
Last Seen                     Wed 27 Jan 2010 09:56:53 PM MST
Local ID                      34c21889-8d15-4dbc-98c6-ad027ca78276
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1264654613.466:31934): avc:  denied  { getattr } for  pid=2231 comm="abrt-hook-pytho" name="/" dev=dm-0 ino=2 scontext=unconfined_u:unconfined_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem

node=(removed) type=SYSCALL msg=audit(1264654613.466:31934): arch=c000003e syscall=137 success=yes exit=0 a0=4021e1 a1=7ffff555a260 a2=fdf a3=7ffff555a0a0 items=0 ppid=1919 pid=2231 auid=500 uid=500 gid=500 euid=491 suid=491 fsuid=491 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="abrt-hook-pytho" exe="/usr/libexec/abrt-hook-python" subj=unconfined_u:unconfined_r:abrt_helper_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-73.fc12,catchall,abrt-hook-pytho,abrt_helper_t,fs_t,filesystem,getattr
audit2allow suggests:

#============= abrt_helper_t ==============
allow abrt_helper_t fs_t:filesystem getattr;

Comment 1 Miroslav Grepl 2010-01-28 09:39:10 UTC
Fixed in selinux-policy-3.6.32-78.fc12

selinux-policy-3.6.32-78.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-78.fc12

Comment 2 Guy Streeter 2010-01-28 22:43:43 UTC
This happens every time a python script errors out. It's really annoying.

Comment 3 Dagan McGregor 2010-01-30 10:07:19 UTC
 Just like to note, I have installed the updated version noted above, from updates-testing, rebooted my computer, and I still get the same error. It appears when I first login.

 I am using F12 x86_64

$ uname -r
2.6.31.12-174.2.3.fc12.x86_64

Installed Packages
Name       : selinux-policy
Arch       : noarch
Version    : 3.6.32
Release    : 78.fc12
Size       : 6.6 M
Repo       : installed
From repo  : updates-testing

Name       : selinux-policy-targeted
Arch       : noarch
Version    : 3.6.32
Release    : 78.fc12
Size       : 2.3 M
Repo       : installed
From repo  : updates-testing

$ sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted

Comment 4 wherebrandon_fedora_bugzilla 2010-01-30 17:23:39 UTC
i installed fedora 12 on a lenovo W500.  When i ran the updates this morning i
got this error, and signed up for a redhad bugzilla id, and reported the
error(it is the first of 8 selinux errors)

I have not used alternate/3rd party repos.  i haven't even put in m3 decoding
or dvd watching.

this issue does still exist on 100% redhat/fedora distributed packages, so it
DOES NOT WORK FOR ME.

i will be happy to provide any information from my system to help solve the
problem.

this is preventing yum from working.

i really don't want to disable selinux.  it is there for a good reason.    

same as dagan...
I am using F12 x86_64

$ uname -r
2.6.31.12-174.2.3.fc12.x86_64

sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          permissive
Policy version:                 24
Policy from config file:        targeted

Comment 5 Fedora Update System 2010-02-03 23:18:40 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 6 Fedora Update System 2010-02-05 01:43:08 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 7 Christoph Wickert 2010-02-08 11:52:59 UTC
*** Bug 562440 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-02-11 14:35:49 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.