Bug 55944 - Rpm query and rebuilddb error
Rpm query and rebuilddb error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 04:20 EST by Nicolas Proton
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 04:20:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Proton 2001-11-09 04:20:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
RPM Error when i try to do a rpm query or rpm --rebuilddb
Database corrupted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Using rpm-4.0.2-6x
2. rpm -qa or rpm --rebuilddb

	

Actual Results:  rpm --rebuilddb
rpmdb: header.c:241: regionSwab: Assertion `ie.info.type >= 0 &&
ie.info.type <= 9' failed.
Aborted (core dumped)

Additional info:

Bug is the same as 38454 but i use RH 6.2 and i've 
not /var/lib/rpm/Packages file but only rpm files (packages.rpm, ...). And 
t38454 program doesn't work correctly.
Comment 1 Jeff Johnson 2001-11-09 12:29:46 EST
A rebuild with the 6x version of rpm-4.0.3-1.03 at
    ftp://ftp.rpm.org/pub/rpm/test-4.0.3
should fix you up. Reopen this bug if not.

Note You need to log in before you can comment on or make changes to this bug.