Bug 559496 - [abrt] crash in mc-1:4.7.0.1-1.fc12
Summary: [abrt] crash in mc-1:4.7.0.1-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:efcd76f999c1aecba6126db3344...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-28 10:18 UTC by Michal Hlavinka
Modified: 2013-07-02 23:42 UTC (History)
5 users (show)

Fixed In Version: 4.7.0.2-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:50:46 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (6.93 KB, text/plain)
2010-01-28 10:18 UTC, Michal Hlavinka
no flags Details
reproducer (10.72 KB, application/x-gzip)
2010-01-28 10:19 UTC, Michal Hlavinka
no flags Details

Description Michal Hlavinka 2010-01-28 10:18:18 UTC
abrt 1.0.3 detected a crash.

How to reproduce
-----
1.try to edit attached file 
2.
3.

Comment: it seems it depends on file name, because when file is renamed it does not reproduce itself
Attached file: backtrace
cmdline: /usr/bin/mc -P /home/mhlavink/tmp/mc-mhlavink/mc.pwd.26503
component: mc
executable: /usr/bin/mc
kernel: 2.6.32.6-36.fc12.x86_64
package: mc-1:4.7.0.1-1.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)

Comment 1 Michal Hlavinka 2010-01-28 10:18:21 UTC
Created attachment 387285 [details]
File: backtrace

Comment 2 Michal Hlavinka 2010-01-28 10:19:36 UTC
Created attachment 387286 [details]
reproducer

IzV-Útěk_do_bezpečí.gz - file must have this name

Comment 3 Michal Hlavinka 2010-01-28 10:22:40 UTC
it seems it's also enough to open empty file with the same name:

touch IzV-Útěk_do_bezpečí.gz

unzip will complain, but it will crash and abrt shows this crash as duplicate, so the problem is probably the same

because it seems it's caused by file name, here is my locale:
$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Comment 4 Jindrich Novy 2010-01-28 12:51:18 UTC
Filed upstream: http://www.midnight-commander.org/ticket/1982

The failure happens when mc is trying to free gzip command line via g_free(p).

Comment 5 Slava Zanko 2010-01-29 01:03:08 UTC
(In reply to comment #4)
> Filed upstream: http://www.midnight-commander.org/ticket/1982

Upstream have a fix issue. Need to test.

Not all developers of mc have x86_64 arch (for example, at work my arch is i686), therefore I want ask to Jindrich: if this not hard to you - please, test branch 1982_segfault_on_gz_archive; and if bug fixed - vote into upstream bugreport (just add 'jnovy' into 'Votes for changeset' field). As ticketstarter you may vote.

> The failure happens when mc is trying to free gzip command line via g_free(p).    
Nope, failure happens at edit_get_filter() function (invalid calculation of malloc'ed memory).

Comment 6 Fedora Update System 2010-02-10 13:08:40 UTC
mc-4.7.0.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mc-4.7.0.2-1.fc12

Comment 7 Fedora Update System 2010-02-10 13:10:52 UTC
mc-4.7.0.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mc-4.7.0.2-1.fc11

Comment 8 Fedora Update System 2010-02-11 14:50:29 UTC
mc-4.7.0.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-02-11 14:57:27 UTC
mc-4.7.0.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.