Bug 55960 - broken man-page links in nfs-utils-0.3.3-1
broken man-page links in nfs-utils-0.3.3-1
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: nfs-utils (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On: 56656
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 10:08 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 12:00:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-11-09 10:08:10 EST
/etc/cron.daily/makewhatis.cron:

zcat: ./rpc.lockd.8.gz: No such file or directory
zcat: ./rpc.mountd.8.gz: No such file or directory
zcat: ./rpc.nfsd.8.gz: No such file or directory
zcat: ./rpc.statd.8.gz: No such file or directory
Comment 1 Bob Matthews 2001-11-09 16:05:18 EST
I can't reproduce this bug.  Can you try erasing and reinstalling the nfs-utils
RPM to see if this fixes the problem?  It may be that another package is
stepping on nfs-utils man pages.
Comment 2 Jonathan Kamens 2001-11-11 21:01:23 EST
No, nothing else has stepped on the nfs-utils man pages.

Note, first of all, that "rpm --verify nfs-utils" does not report that any of
the man pages are messed up:

jik:~!85> rpm --verify nfs-utils
Unsatisfied dependencies for nfs-utils-0.3.3-1: kernel >= 2.2.14
S.5....T c /var/lib/nfs/etab
jik:~!86> 

Note, second of all, that "rpm -q -l -v nfs-utils | grep rpc.mountd.8.gz" shows
that indeed, the symbolic link for this (and the other) man pages is messed up
in the RPM itself, not just on my system:

jik:~!88> rpm -q -l -v nfs-utils | grep rpc.mountd.8.gz
lrwxrwxrwx    1 root    root                3 Nov  7 16:44
/usr/share/man/man8/rpc.mountd.8.gz -> .gz
jik:~!89> 

Note what the symlink is pointing at in the "rpm -q -l -v" output.

If you can't reproduce this, perhaps it is fixed in a later, unreleased version
of the nfs-utils RPM.
Comment 3 Bob Matthews 2001-11-12 14:33:58 EST
Well, I still can't reproduce this.  The odd thing is that I'm testing the same
version of nfs-utils as you are.

[root@xxx root]# rpm -q nfs-utils
nfs-utils-0.3.3-1
[root@xxx root]# rpm -q -v -l nfs-utils | grep man | grep rpc
lrwxrwxrwx    1 root    root               10 Nov  7 14:49
/usr/share/man/man8/rpc.lockd.8.gz -> lockd.8.gz
lrwxrwxrwx    1 root    root               11 Nov  7 14:49
/usr/share/man/man8/rpc.mountd.8.gz -> mountd.8.gz
lrwxrwxrwx    1 root    root                9 Nov  7 14:49
/usr/share/man/man8/rpc.nfsd.8.gz -> nfsd.8.gz
lrwxrwxrwx    1 root    root               10 Nov  7 14:49
/usr/share/man/man8/rpc.statd.8.gz -> statd.8.gz
[root@xxx root]# ls -l /usr/share/man/man8/{lockd,mountd,nfsd,statd}.8.gz
-rw-r--r--    1 root     root          376 Nov  7 14:49
/usr/share/man/man8/lockd.8.gz
-rw-r--r--    1 root     root         1741 Nov  7 14:49
/usr/share/man/man8/mountd.8.gz
-rw-r--r--    1 root     root          702 Nov  7 14:49
/usr/share/man/man8/nfsd.8.gz
-rw-r--r--    1 root     root         1530 Nov  7 14:49
/usr/share/man/man8/statd.8.gz
Comment 4 Jonathan Kamens 2001-11-12 14:56:57 EST
Perhaps there are two nfs-utils packages with the same version and release
number floating around?

jik:/usr/src/packages!17> ls -l nfs-utils-0.3.3-1.i386.rpm 
-rw-rw-r--    1 jik      jik        187266 11-07 16:44 nfs-utils-0.3.3-1.i386.r\
pm
jik:/usr/src/packages!18> sum nfs-utils-0.3.3-1.i386.rpm
04913   183
jik:/usr/src/packages!19> 
Comment 5 Bob Matthews 2001-11-12 15:10:35 EST
> Perhaps there are two nfs-utils packages with the same version and release
 number floating around?

[root@xxx root]# ls -l nfs-utils-0.3.3-1.i386.rpm 
-rw-r--r--    1 root     root       187328 Nov  9 12:01
nfs-utils-0.3.3-1.i386.rpm
[root@xxx root]# sum nfs-utils-0.3.3-1.i386.rpm 
62753   183

Yep, you're right.

Either we have two packages with the same version floating around, in which case
we have serious trouble, or the one you got was corrupted.  What does rpm -K
say?
Comment 6 Jonathan Kamens 2001-11-12 15:18:27 EST
rpm -K says that the md5 on the package is OK.

Note that the RPM I've got is the same size as the one in the rawhide directory
on ftp.redhat.com.
Comment 7 Pete Zaitcev 2004-04-19 12:00:21 EDT
Over the horizon bug.

Note You need to log in before you can comment on or make changes to this bug.