Bug 559676 - [abrt] crash in thunderbird-3.0.1-1.fc12
[abrt] crash in thunderbird-3.0.1-1.fc12
Status: CLOSED DUPLICATE of bug 551892
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
abrt_hash:c28576190ff4a70a75fb40a9004...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-28 13:10 EST by Mostafa Daneshvar
Modified: 2010-02-23 09:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 09:53:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (107.69 KB, text/plain)
2010-01-28 13:10 EST, Mostafa Daneshvar
no flags Details
rpm -qa *thunderbird* *mozilla* *flash* *plugin* (1.42 KB, application/octet-stream)
2010-01-28 19:02 EST, Mostafa Daneshvar
no flags Details

  None (edit)
Description Mostafa Daneshvar 2010-01-28 13:10:31 EST
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/thunderbird-3.0/thunderbird-bin
component: thunderbird
executable: /usr/lib/thunderbird-3.0/thunderbird-bin
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: thunderbird-3.0.1-1.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)
Comment 1 Mostafa Daneshvar 2010-01-28 13:10:35 EST
Created attachment 387399 [details]
File: backtrace
Comment 2 Chris Campbell 2010-01-28 18:41:45 EST
#7  0x00484be8 in __assert_fail (assertion=<value optimized out>, 
    file=<value optimized out>, line=<value optimized out>, 
    function=<value optimized out>) at assert.c:81
        buf = 
    0xa72d3650 "thunderbird-bin: xcb_io.c:378: _XAllocID: Assertion `ret != inval_id' failed.\n"
#8  0x007fbc0a in _XAllocID (dpy=0xb7548000) at xcb_io.c:378
        ret = 4294967295
        __PRETTY_FUNCTION__ = "_XAllocID"
#9  0x007d0f19 in XCreatePixmap (dpy=<value optimized out>, 
    d=<value optimized out>, width=<value optimized out>, 
    height=<value optimized out>, depth=<value optimized out>)
    at CrPixmap.c:58
No locals.
#10 0x00d9ae63 in _cairo_xlib_surface_create_similar_with_format (
    abstract_src=0xa9b1e9b0, format=<value optimized out>, width=8, height=30)
    at cairo-xlib-surface.c:155
        dpy = 0xb7548000
        pix = 3075768320
        xrender_format = <value optimized out>
#11 0x00d9fd24 in _cairo_xlib_surface_clone_similar (abstract_surface=
    0xa9b1e9b0, src=0xa72bc100, src_x=0, src_y=0, width=8, height=30, 
    clone_offset_x=0xbfaebafc, clone_offset_y=0xbfaebaf8, clone_out=
    0xbfaebe4c) at cairo-xlib-surface.c:1201
        status = <value optimized out>




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-01-28 18:48:53 EST
Thank you for taking the time to submit this bug report.

We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command, saved in a text file and attached to this bug:

 $ rpm -qa *thunderbird* *mozilla* *flash* *plugin*

Please also install thunderbird-debuginfo.

 # debuginfo-install thunderbird

Then run thunderbird inside the gdb debugger. Please do the following:

 $ thunderbird -g

Stuff will appear. Ignore this until you get the gdb command prompt, then do:

 (gdb) run

Now, thunderbird should start up. Use it and reproduce the crash. When thunderbird crashes, you should be back to the gdb prompt. Now do:

 (gdb) thread apply all back-trace

More screens of stuff will occur. Copy all of this part to your editor of choice, such as gedit, and save it as an uncompressed file and attach it to this bug report.

We will review this issue again once you've had a chance to attach this information.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Mostafa Daneshvar 2010-01-28 19:02:19 EST
Created attachment 387460 [details]
rpm -qa *thunderbird* *mozilla* *flash* *plugin*

out put of rpm -qa *thunderbird* *mozilla* *flash* *plugin*
Comment 5 Chris Campbell 2010-01-29 13:59:53 EST
Reporter, will it be possible for you to attempt to reproduce this under the debugger? I am hoping to get a more thorough back-trace. If not, I can forward this as is.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Mostafa Daneshvar 2010-01-29 14:19:41 EST
(In reply to comment #5)
> Reporter, will it be possible for you to attempt to reproduce this under the
> debugger? I am hoping to get a more thorough back-trace. If not, I can forward
> this as is.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers    

I've followed instruction give by you, there is no crash up to now
Comment 7 Chris Campbell 2010-01-29 19:16:25 EST
Going to go ahead and set this one to Triaged and forward to a dev. Thank you for your extra efforts.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Jan Horak 2010-02-23 09:53:13 EST

*** This bug has been marked as a duplicate of bug 551892 ***

Note You need to log in before you can comment on or make changes to this bug.