Bug 559679 - Starting HAL demon: /bin/bash: line 1: Trace/breakpoint trap
Starting HAL demon: /bin/bash: line 1: Trace/breakpoint trap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Alpha/F13AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-01-28 13:22 EST by John Reiser
Modified: 2013-01-10 00:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 12:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2010-01-28 13:22:21 EST
Description of problem:  Booting to multiuser leaves a severely crippled system because hald gets a trace/breakpoint trap and does not initialize devices (keyboard, network, ...)

Version-Release number of selected component (if applicable):
hal-0.5.14-2.fc13.x86_64.rpm

How reproducible: always


Steps to Reproduce:
1. boot to multi-user (level 3 or level 5)
2.
3.
  
Actual results:
"Starting HAL demon: /bin/bash: line 1: Trace/breakpoint trap"
and the network is not up (and "ifup eth0" complains that eth0 is not present), and there is no response to keyboard.

Expected results:  Normal multi-user system with keyboard and network.

Additional info:
Comment 1 Will Woods 2010-01-28 13:35:51 EST
This is reportedly an SELinux issue "triggered by the change in gobject to enable threads by default". 

It's thought to be fixed in selinux-policy-3.7.8-5.fc13:
http://koji.fedoraproject.org/koji/buildinfo?buildID=153441
Comment 2 Adam Williamson 2010-01-28 15:37:44 EST
I can confirm the bug and the fix here: no input (even at runlevel 3, for me...) with today's Rawhide, the updated selinux-policy fixes it. Added a note to Rawhide Watch:

http://rawhidewatch.wordpress.com/2010/01/28/no-input-when-booting-rawhide-of-2010-01-28/
Comment 3 Adam Williamson 2010-02-05 12:14:17 EST
This is fixed in Rawhide now.

Note You need to log in before you can comment on or make changes to this bug.