Bug 55970 - loads usb audio driver blocking emu10k1 driver from working
loads usb audio driver blocking emu10k1 driver from working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 11:55 EST by Need Real Name
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 15:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-09 11:55:59 EST
Description of Problem:
After 7.2 boots, the only sound service available is my usb microphone (on
my Logitech QuickCam 3000). My Creative Labs Live soundcard is not shown in
any of the mixers. I have to '/sbin/rmmod audio' to get my soundcard to
work. Once I do that the sound card will be shown in the mixer and the usb
audio module will *magically* reload and be in the mixer too.

Version-Release number of selected component (if applicable):
hotplug-2001_04_24-11

How Reproducible:
Just boot 7.2 with a usb microphone (say on a webcam) and a Sound Blaster
sound card installed.

Steps to Reproduce:
1. Boot Red Hat 7.2
2. Open any mixer (i.e. gmix), see that USB Class Audio is only device
3. su to root, /sbin/rmmod audio
4. See that Creative Labs Sound Blaster Live and USB Class Audio devices
are both shown in mixer.
5. I can now play MP3's

Actual Results:
I could (after completing the steps) properly use my soundcard.

Expected Results:
The usb audio module should not be loaded first or in a fashion that blocks
the more crucial emu10k1 driver from working properly.

Additional Information:
I'll let the bug fixer ssh into my system if they want, so they can see
what's going on.
Comment 1 Trond Eivind Glomsrxd 2001-11-09 12:25:50 EST
I understand the problem, but can't think of a fix right know... for a
workaround, you can put the driver in /etc/hotplug/blacklist
Comment 2 Bryce Nesbitt 2002-03-22 14:18:16 EST
For me the problem is present, but just annoying.  Both my scsi CDROM and my
built in audio device change numbers if a USB device is plugged in at boot.

USB devices must be recognized after motherboard devices, to keep things
predictable.
Comment 3 Trond Eivind Glomsrxd 2002-04-11 15:08:20 EDT
"alias audio off" in modules.conf works well... anyway, I think this is more of
an initscripts issue... soundcards must be initialized earlier, to avoid this.
Comment 4 Bill Nottingham 2002-04-11 15:21:41 EDT
initscripts does not initialize pci sound cards.
Comment 5 Bill Nottingham 2005-02-04 15:47:38 EST
Closing out bugs on older, no longer supported, releases. Apologies
for any lack of response.

This is fixed in FC3 with the new hardware initialization on boot.

Note You need to log in before you can comment on or make changes to this bug.