Bug 55973 - cannot su with pam 0.75-16
cannot su with pam 0.75-16
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 13:07 EST by Need Real Name
Modified: 2013-07-02 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 10:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-09 13:07:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:
Cannot su after updating pam 0.75-14 to pam 0.75-16. Had to reinstall os
and update everything except pam 0.75-14 in order to have access to files
as superuser 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.update pam 0.75-14 to pam 0.75-16
2.
3.
	

Actual Results:  Lost ability to su

Expected Results:  This update is supposed to fix this type of problem with
systems using passwords of 8 or more characters. Instead it produced this
problem on my system.

Additional info:
Comment 1 Need Real Name 2001-11-12 15:24:49 EST
I did not have a problem as root, only when logged in as user and su to root.
Also same GUI problem as bug 55661 report, but also was unable to have root
privliges to rewrite files after su.
Comment 2 Nalin Dahyabhai 2001-11-13 15:49:53 EST
Which authentication systems are configured on this machine?  Are you using md5
passwords?  Shadow passwords?  NIS?  Is root's entry in /etc/passwd (or
/etc/shadow, if using shadow) hashed with an md5 crypt (if it is, the second
field will start with "$1$") or with a conventional crypt (if it is, it'll be
exactly 13 characters long, and should contain only characters from the set
"A-Za-z0-9")?
Comment 3 pogosyan 2002-01-07 13:55:56 EST
I have the same problem, as part of larger authentication problems I encountered
after
upgrading to pam-0.75-20   (first - 0.75-19 from 7.2 updates)

for user account, plain su does not switch to root ( password is accepted, but
permissions
are not granted).   su -l root   works all right.   Bsed on your description, I
have shadow,
MD5 encrypted passwords, no NIS.   My password is 9 characters long, mixture of
alphabethical and numerals and '_'.

I use 2.4.16-0.13 kernel and glibc libraries on top of RH7.2 installation.

My large problem is that after I upgraded pam  (already with new kernel and
glibc),
I cannot login through gdm neither to root, nor to user account. My user
password is
8 characters, mixture of lower and upper case alphabethical.  Session is getting
setup
and immediately exits. I run gdm with debug unabled - nothing suspicious - 
gdm sets cookie to .Xauthority, runs /etc/X11/gdm/Init/Default and session
immediately
exits after that (it does not matter what desktop I choose).

It has to do with authentication, since I can run plain startx or xdm all right
- I'm getting
Gnome desktop. However, I'm unable to open any terminals then - any of them
(gnome-terminal,
rxvt, xterm) just blink on the screen and disappear.  I can however run Netscape
and
many other applications.

Dowgrading pam back to RH7.2 or RH7.1 version did not help.  Neither did
changing
pam_unix to pam_pwdb   as was suggested in other bug discussion.  Although I may
have not
done all checks consistenly.

Note You need to log in before you can comment on or make changes to this bug.