Bug 55977 - [qlogic] Installation hangs with add-in adapters.
[qlogic] Installation hangs with add-in adapters.
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: 54736 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-11-09 13:57 EST by Stephen Elia
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-10 12:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Elia 2001-11-09 13:57:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When installing RedHat 7.2 RC3 the install will hang just before the GUI 
loads (This configuration also hangs with RC2). I tried this same 
configuration on 7.2 RC1 with no problems whatsoever.

4 x 800MHz (C1) Itanium Processors
Bios 101b (99b also failed)
HSC 07
BMC 26
SDR 14
CBC 02

PCI-1 Adaptec 29160 Host Adapter
PCI-2 QLogic QLA2200-66 Fiber Chanel Host Adapter
PCI-3 QLogic QLA2200-66 Fiber Chanel Host Adapter
PCI-4 AMI 1600 Enterprise Host Adapter.
PCI-5 Intel Pro 100+ Server 8470B
PCI-6 Intel Pro 100+ Server 8470B
PCI-7 Intel Pro 1000 Gigabit Server Adapter
PCI-8 Intel Pro 1000 Gigabit Server Adapter
PCI-9 Empty
PCI-10 Intel Pro 100+ Server Adapter 8470B

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Configure machine as described above.
2.Start installer
3.Installer hangs.

Actual Results:  Installation would proceed as normal (without hanging).

Expected Results:  X should have started.

Additional info:
Comment 1 Matthew Tolentino 2001-11-09 16:07:05 EST
As another datapoint, I was able to reproduce this failure as well.  Failure 
occurred when loading the drivers for the adapters in the system.  However, if 
I turned off the slot that contained the AMI 1600 (or removed it), the 
installation proceeded as expected.
Comment 2 Bill Nottingham 2001-11-09 16:47:52 EST

1 - Adapted 29160 and 39160
2 - Qlogic QLA2200
3 - Qlogic QLA2200
4 - AMI Megaraid 493
5 - Intel Dual EEPro 100
6 - Intel Dual EEPro 100
7 - Intel Pro 1000 (copper)
8 - Intel Pro 10000 (fiber)
9 - empty
10 - Intel EEPro 100

- in all boots but one, machine failed to get out of BIOS. Normally hangs
  at 'initializing timer'
- once, booted succesfully to EFI shell. Then, elilo hung, presumably
  attempting to get EDD3.0 information from the various storage controllers.

So, we can not reproduce this here, because we can not reproduce the HW
configuration here. Can you simplify the test case? Does it really require *all*
these adapters installed to fail?
Comment 3 Stephen Elia 2001-11-09 18:43:55 EST
Additional testing revealed that the adapters in slots 1, 2 and 3 cause the 
failure as well.

PCI-1 Adaptec 29160 Host Adapter
PCI-2 QLogic QLA2200-66 Fiber Chanel Host Adapter
PCI-3 QLogic QLA2200-66 Fiber Chanel Host Adapter
Comment 4 Bill Nottingham 2001-11-14 16:49:38 EST
In fact, the machine continues to hang at 'Initializing timer', even after
all cards have been removed. Hence, the machine completely useless after the
cards are inserted in this manner.  We have reproduced this on a second machine,
and are supsending investigation of this bug for the safety of our ia64 hardware.
Comment 5 Matt Domsch 2001-11-14 21:47:04 EST
Bill wedged our PowerEdge 7150 doing this. :-(
Comment 6 Michael K. Johnson 2001-11-15 15:08:57 EST
The kernel hangs, no VC switching happens.  This is not the installer
process hanging.
Comment 7 Matthew Tolentino 2001-11-16 17:24:21 EST
Correct, this hang occurs before X starts.  I have been able to reliably 
reproduce this w/o hitting the hang at 'Initializing timer...' observed at RH.  
I have been working with a subset of the adapters Stephen posted.  My findings 
thus point to the driver for the Qlogic 2200/FC Adapter.  Here are my results 
of several tests:
For all tests:
Slot1: Adaptec 29160
Slot2: Qlogic 2200/FC
Slot3: Qlogic 2200/FC
Slot4: AMI 1600

I also have a pro/1000 and an extra pro/100 in the system in further slots, but 
they do not appear to be causing the problems...

  Slots 1-4 populated
-- on load of 12160 driver, "KERNEL PANIC: Invalid or not present host"
  Slots 1-4 populated
-- screen blanked on load of Qlogic 2200 driver
  Slots 1-2 populated
-- on load of 12160 driver, "KERNEL PANIC: Invalid or not present host"
  Same as TEST2
  Slots 2-3 only populated 
-- screen blank when loading the Qlogic 2200 driver
  No Qlogics 2200s in system - slots 2 & 3 left empty, 29160 and AMI1600 still 
in system
-- SUCCESS!  Installer started as expected.

Only a little bit of probing showed the kernel panic originated from the scsi 
sub-system - specifically scsi.c in the 1.) scsi_do_req 2.) 
scsi_init_cmd_from_req and 3.) scsi_do_cmd routines.

Based on these results, culprit appears to be the Qlogic 2200 driver.
Comment 8 Matthew Tolentino 2001-11-16 17:36:59 EST
Also, have you tried clearing the CMOS on the hun system?
Comment 9 Bill Nottingham 2001-11-28 15:40:52 EST
sounds like a kernel qla2x00 driver issue.
Comment 10 Michael K. Johnson 2001-12-01 08:06:05 EST
The next tree AFTER the qa1129 tree will load the qla2200 driver insteaed of
the qla2x00 driver for ISP2200 cards.  We would like to know if that fixes
the problem when that occurs.
Comment 11 Michael K. Johnson 2001-12-10 12:21:51 EST
Unless we hear otherwise, I'm going to assume that qa1207.0 fixed this
bug.  We have fixed a lot of qla2200 bugs that could have caused this,
and we are not reproducing hangs like this here now.
Comment 12 Stephen Elia 2001-12-10 17:47:16 EST
qa1207 has fixed the installation issues we have encountered.  Closing
Comment 13 Mike A. Harris 2002-07-26 07:07:23 EDT
*** Bug 54736 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.