Bug 559819 - SELinux is preventing /usr/sbin/pppd "sys_admin" access.
Summary: SELinux is preventing /usr/sbin/pppd "sys_admin" access.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:41f3a16024b...
: 560156 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-29 04:30 UTC by Eugene Kanter
Modified: 2010-02-11 14:42 UTC (History)
3 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:42:56 UTC


Attachments (Terms of Use)

Description Eugene Kanter 2010-01-29 04:30:20 UTC
Summary:

SELinux is preventing /usr/sbin/pppd "sys_admin" access.

Detailed Description:

SELinux denied access requested by pppd. It is not expected that this access is
required by pppd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:pppd_t:s0
Target Context                system_u:system_r:pppd_t:s0
Target Objects                None [ capability ]
Source                        pppd
Source Path                   /usr/sbin/pppd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ppp-2.4.4-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-73.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.12-174.2.3.fc12.i686 #1 SMP
                              Mon Jan 18 20:22:46 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Thu 28 Jan 2010 11:20:05 PM EST
Last Seen                     Thu 28 Jan 2010 11:20:05 PM EST
Local ID                      9fc2b5cb-054c-4890-af96-34180564858f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1264738805.327:110): avc:  denied  { sys_admin } for  pid=3594 comm="pppd" capability=21 scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:pppd_t:s0 tclass=capability

node=(removed) type=SYSCALL msg=audit(1264738805.327:110): arch=40000003 syscall=5 success=no exit=-16 a0=ba6ca0 a1=802 a2=0 a3=b641a0 items=0 ppid=3589 pid=3594 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="pppd" exe="/usr/sbin/pppd" subj=system_u:system_r:pppd_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-73.fc12,catchall,pppd,pppd_t,pppd_t,capability,sys_admin
audit2allow suggests:

#============= pppd_t ==============
allow pppd_t self:capability sys_admin;

Comment 1 Eugene Kanter 2010-01-29 04:36:12 UTC
From /var/log/messages:

Jan 28 23:20:04 localhost kernel: usb 3-2: new full speed USB device using uhci_hcd and address 3
Jan 28 23:20:04 localhost kernel: usb 3-2: New USB device found, idVendor=0bb4, idProduct=0a51
Jan 28 23:20:04 localhost kernel: usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 28 23:20:04 localhost kernel: usb 3-2: Product: USB Serial for Treo 700w
Jan 28 23:20:04 localhost kernel: usb 3-2: Manufacturer: Palm
Jan 28 23:20:04 localhost kernel: usb 3-2: SerialNumber: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
Jan 28 23:20:04 localhost kernel: usb 3-2: configuration #1 chosen from 1 choice
Jan 28 23:20:04 localhost kernel: usbcore: registered new interface driver usbserial
Jan 28 23:20:04 localhost kernel: USB Serial support registered for generic
Jan 28 23:20:04 localhost kernel: usbcore: registered new interface driver usbserial_generic
Jan 28 23:20:04 localhost kernel: usbserial: USB Serial Driver core
Jan 28 23:20:04 localhost kernel: USB Serial support registered for PocketPC PDA
Jan 28 23:20:04 localhost kernel: ipaq 3-2:1.0: PocketPC PDA converter detected
Jan 28 23:20:04 localhost kernel: usb 3-2: PocketPC PDA converter now attached to ttyUSB0
Jan 28 23:20:04 localhost kernel: usbcore: registered new interface driver ipaq
Jan 28 23:20:04 localhost kernel: ipaq: v0.5:USB PocketPC PDA driver
Jan 28 23:20:04 localhost modem-manager: (ttyUSB0) opening serial device...
Jan 28 23:20:05 localhost pppd[3589]: Warning: can't open options file /root/.ppprc: Permission denied
Jan 28 23:20:05 localhost kernel: PPP generic driver version 2.4.2
Jan 28 23:20:05 localhost pppd[3594]: pppd 2.4.4 started by root, uid 0
Jan 28 23:20:05 localhost pppd[3594]: Failed to open /dev/ttyUSB0: Device or resource busy
Jan 28 23:20:05 localhost pppd[3594]: Exit.

Comment 2 Daniel Walsh 2010-01-29 14:24:37 UTC
Miroslav add sys_admin to pppd_t

And add this label for /root/.ppprc
/root/.ppprc			--	gen_context(system_u:object_r:pppd_etc_t,s0)

Comment 3 Miroslav Grepl 2010-02-01 10:15:47 UTC
*** Bug 560156 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-02-01 14:04:59 UTC
Fixed in selinux-policy-3.6.32-80.fc12

Comment 5 Fedora Update System 2010-02-03 23:19:26 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 6 Fedora Update System 2010-02-05 01:45:30 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 7 Fedora Update System 2010-02-11 14:38:20 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.