Bug 559828 - Crash when saving picture with empty description on FLAC file
Summary: Crash when saving picture with empty description on FLAC file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easytag
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 544533 562609 563283 578646 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-29 05:32 UTC by Michael Cronenworth
Modified: 2010-05-12 18:02 UTC (History)
4 users (show)

Fixed In Version: easytag-2.1.6-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 17:52:56 UTC


Attachments (Terms of Use)
easytag seg fault backtrace (20.09 KB, text/plain)
2010-01-29 05:33 UTC, Michael Cronenworth
no flags Details
One liner fix (379 bytes, patch)
2010-03-02 03:43 UTC, Michael Cronenworth
no flags Details | Diff

Description Michael Cronenworth 2010-01-29 05:32:44 UTC
Version-Release number of selected component (if applicable): easytag-2.1.6-2.fc12.x86_64


How reproducible: Always. Any FLAC file.


Steps to Reproduce:
1. Open a FLAC file.
2. Go to the picture tab, add a picture.
3. Edit the picture and erase the description.
4. Save the file.
  
Actual results: Seg fault.


Expected results: Newly written metadata.


Additional info: Backtrace is attached. abrt didn't catch this crash for some reason...

Comment 1 Michael Cronenworth 2010-01-29 05:33:28 UTC
Created attachment 387500 [details]
easytag seg fault backtrace

Comment 2 Michael Cronenworth 2010-03-02 03:43:10 UTC
Created attachment 397237 [details]
One liner fix

Here's the one liner fix for the problem. The author set the picture description pointer to NULL and attempted to pass this to the FLAC lib function, which is incorrect. The patch will strdup() an empty string, which will be treated the same as if there was a description buffer. I successfully wrote new metadata to a FLAC file with the attached patch and metaflac successfully parsed and displayed the new metadata without error.

As it's been two years since upstream has released a version, and upstream has not responded to my e-mail about this bug, what are the chances that this patch will make it anywhere beyond this bug report?

Comment 3 Matthias Saou 2010-04-30 14:50:27 UTC
*** Bug 578646 has been marked as a duplicate of this bug. ***

Comment 4 Matthias Saou 2010-04-30 14:54:18 UTC
*** Bug 563283 has been marked as a duplicate of this bug. ***

Comment 5 Matthias Saou 2010-04-30 14:55:18 UTC
*** Bug 562609 has been marked as a duplicate of this bug. ***

Comment 6 Matthias Saou 2010-04-30 15:24:20 UTC
I'll include this fix (and at least one other) in the next update of the package. Sorry for the delay in getting this done...

Comment 7 Matthias Saou 2010-04-30 17:07:08 UTC
*** Bug 544533 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-05-03 08:29:28 UTC
easytag-2.1.6-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc12

Comment 9 Fedora Update System 2010-05-03 08:29:42 UTC
easytag-2.1.6-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc13

Comment 10 Fedora Update System 2010-05-03 08:29:53 UTC
easytag-2.1.6-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc11

Comment 11 Fedora Update System 2010-05-04 06:15:51 UTC
easytag-2.1.6-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc13

Comment 12 Fedora Update System 2010-05-04 06:17:19 UTC
easytag-2.1.6-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc12

Comment 13 Fedora Update System 2010-05-04 06:23:49 UTC
easytag-2.1.6-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc11

Comment 14 Fedora Update System 2010-05-12 17:52:43 UTC
easytag-2.1.6-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-05-12 18:00:12 UTC
easytag-2.1.6-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-05-12 18:02:24 UTC
easytag-2.1.6-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.