Bug 559843 - SELinux is preventing /usr/bin/metacity "write" access on /var/run/pulse/native.
Summary: SELinux is preventing /usr/bin/metacity "write" access on /var/run/pulse/native.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:4a129b50b32...
: 561009 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-29 06:50 UTC by M J
Modified: 2010-02-11 14:43 UTC (History)
4 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:43:01 UTC


Attachments (Terms of Use)
Miroslav add this patch to allow this access. (2.87 KB, application/octet-stream)
2010-02-01 16:21 UTC, Daniel Walsh
no flags Details

Description M J 2010-01-29 06:50:11 UTC
Summary:

SELinux is preventing /usr/bin/metacity "write" access on /var/run/pulse/native.

Detailed Description:

SELinux denied access requested by metacity. It is not expected that this access
is required by metacity and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_run_t:s0
Target Objects                /var/run/pulse/native [ sock_file ]
Source                        canberra-gtk-pl
Source Path                   /usr/bin/canberra-gtk-play
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           metacity-2.28.0-14.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-73.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.6-166.fc12.i686.PAE #1
                              SMP Wed Dec 9 11:00:30 EST 2009 i686 i686
Alert Count                   17
First Seen                    Sun 24 Jan 2010 05:10:43 PM MST
Last Seen                     Thu 28 Jan 2010 11:37:07 PM MST
Local ID                      c8bb8258-d357-4b00-aab0-68a08b1b7a12
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1264747027.474:25691): avc:  denied  { write } for  pid=5058 comm="metacity" name="native" dev=dm-0 ino=5898244 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1264747027.474:25691): arch=40000003 syscall=102 success=no exit=-13 a0=3 a1=bf8cf5d0 a2=2c74208 a3=9d7f4d0 items=0 ppid=5045 pid=5058 auid=4294967295 uid=42 gid=475 euid=42 suid=42 fsuid=42 egid=475 sgid=475 fsgid=475 tty=(none) ses=4294967295 comm="metacity" exe="/usr/bin/metacity" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-73.fc12,catchall,canberra-gtk-pl,xdm_t,var_run_t,sock_file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_run_t:sock_file write;

Comment 1 Daniel Walsh 2010-01-29 14:11:12 UTC
Something strange is going on here?  Why is xdm_t running metacity?

Comment 2 Ray Strode [halfline] 2010-01-29 17:49:38 UTC
the login screen needs a window manager.  It's metacity by default.

Comment 3 Daniel Walsh 2010-02-01 16:03:51 UTC
Is /var/run/pulse/native  something new?

I do not have it on my machines?

Comment 4 Daniel Walsh 2010-02-01 16:21:12 UTC
Created attachment 388075 [details]
Miroslav add this patch to allow this access.

Comment 5 Miroslav Grepl 2010-02-01 19:11:10 UTC
Fixed in selinux-policy-3.6.32-80.fc12

Comment 6 Daniel Walsh 2010-02-02 14:46:11 UTC
*** Bug 561009 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2010-02-03 23:19:31 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 8 Fedora Update System 2010-02-05 01:45:34 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 9 Fedora Update System 2010-02-11 14:38:25 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.