Bug 55985 - netstat weirdness
netstat weirdness
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 16:27 EST by Frank Hirtz
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-23 04:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Hirtz 2001-11-09 16:27:23 EST
Description of Problem:

we've seen 2 strange problems:

1) netstat displays 2 identical lines

netstat -a |grep piics2
tcp        0      0 hqias4:mtflocal         piics2:33135
ESTABLISHED
tcp        0      0 hqias4:mtflocal         piics2:33135
ESTABLISHED

2) netstat display this:

 warning, got bogus tcp line.
------------------------------
tcp        0      0 hqias4:mtflocal         piics2:33235
ESTABLISHED ufilter    7312379
------------------------------
warning, got bogus tcp line.

---
Preston evaluated this and indicated that it could affect the performance
of anything using the proc/net/tcp, but it was possible to change netstat
to filter for duplicate entries. 

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Phil Knirsch 2002-02-24 07:36:20 EST
Could you be a little more specific in how to recreate this problem? Otherwise
it's kinda hard to check if a fix actually fixes the problem.

Thanks,

Read ya, Phil
Comment 2 Phil Knirsch 2003-05-23 04:08:38 EDT
I still cannot reproduce this bug. Closing as works for me now.

Read ya, Phil
Comment 3 Vikul 2004-03-19 14:24:05 EST
I am getting this error but not on a consistent basis. One more thing 
which might help replicating the issue is that we have too many 
connections in the CLOSING state.

Note You need to log in before you can comment on or make changes to this bug.