Bug 55988 - Upgrading from 6.2 to 7.2 breaks graphical login
Upgrading from 6.2 to 7.2 breaks graphical login
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 16:38 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 06:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-09 16:38:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
If you install redhat 6.2, make changes to /etc/X11/xdm/Xsession or
Xsetup_0, then upgrade to 7.2 using the cds, you will find that the
existing Xsession and Xsetup_0 will be renamed to *.rpmsave, and the new
ones will be named *.rpmnew.  When you try to log in, you'll get the
failsafe Xterm session instead of kde or gnome.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Install RedHat 6.2
2.Modify /etc/X11/xdm/Xsession or Xsetup_0
3.Upgrade to RedHat 7.2
4.Try to login
	

Actual Results:  Instead of KDE or Gnome, you get the failsafe session.

Expected Results:  A window manager should have started

Additional info:

Renaming *.rpmsave or *.rpmnew to * fixes the problem.
Comment 1 Mike A. Harris 2002-08-08 06:44:27 EDT
Hmm. What modifications were made to these files?  Could you attach
the modified files?  Perhaps your modifications are something worthy
of consideration to add to the default files.

I'll look into this issue probably during our next development cycle.
Comment 2 Mike A. Harris 2002-09-05 16:10:30 EDT
Closing bug due to lack of response.  Please reopen and update the
report with new information if the problem is still an issue and you
would still like to see it addressed in future releases.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.