Bug 559917 - sblim-sfcb initscript improvement
Summary: sblim-sfcb initscript improvement
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sblim-sfcb
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: srinivas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 559920 (view as bug list)
Depends On:
Blocks: InitScriptsProject 583979
TreeView+ depends on / blocked
 
Reported: 2010-01-29 10:47 UTC by Yulia Kopkova
Modified: 2010-04-22 12:26 UTC (History)
5 users (show)

Fixed In Version: sblim-sfcb-1.3.7-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 583979 (view as bug list)
Environment:
Last Closed: 2010-04-22 12:26:49 UTC
Type: ---


Attachments (Terms of Use)

Description Yulia Kopkova 2010-01-29 10:47:17 UTC
Description of problem:
According to https://fedoraproject.org/wiki/Packaging/SysVInitScript sblim-sfcb
component init script have one lsb compliance issue:

1. Initscript should return code "2", when program is dead and /var/lock lock file exists:
# service sblim-sfcb start ; echo $?
0tarting sfcb:                                             [  OK  ]
# ps ax | grep sfcb
 7257 ?        S      0:00 /usr/sbin/sfcbd -d
 7264 pts/0    S+     0:00 grep sfcb
# kill -11 7257
# ps ax | grep sfcb
 7268 pts/0    S+     0:00 grep sfcb
# ls -l /var/lock/subsys/sblim-*
-rw-r--r--. 1 root root 0 2010-01-29 11:07 /var/lock/subsys/sblim-sfcb
# service sblim-sfcb status ; echo $?
sfcbd is stopped
3
now: 3
expected: 2 

2. Init script should return code "4" if restarting service under
nonprivileged user:
# su testuserqa -c "service sblim-sfcb restart"; echo $?
rm: cannot remove `/var/lock/subsys/sblim-sfcb': Permission denied]
touch: cannot touch `/var/lock/subsys/sblim-sfcb': Permission denied
1
now: 1
expected: 4

3. On nonexist action initscript should return code "2":
# service sblim-sfcb nonexist ; echo $?
Usage: sfcb {start|stop|status|reload|restart|condrestart}
1
now: 1
expected: 2

4. force-reload action recommended to be supported

5. try-restart action recommended to be supported

Comment 1 Yulia Kopkova 2010-01-29 13:24:44 UTC
*** Bug 559920 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.