Bug 55992 - DHCP times out trying to establish eth0 connection to ADSL supplier
DHCP times out trying to establish eth0 connection to ADSL supplier
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 17:25 EST by Need Real Name
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-24 12:14:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile & Hardware config excerpts (1.89 KB, text/plain)
2001-11-09 17:26 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-09 17:25:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
On bootup, when eth0 is trying to configure the network via DHCP, the
message returns:
Determining IP information for eth0: failed.





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 7.2 on Digital Celebris 6180
2. Choose "configure w/ DHCP" and connect at startup as install options
3. Boot the system.  DHCP times out when attempting to bring up eth0
	

Actual Results:  DHCP fails to configure eth0 connection.

Expected Results:  DHCP configures eth0 with net address from server. 
Network connection is established.

Additional info:

My system is a Digital Celebris 6180 w/ integrated ethernet.
My ADSL supplier is Cincinnati Bell (Zoomtown is the product).

Red Hat 7.0 worked out of the box using DHCP to connect, using the same
hardware and ADSL supplier.  Also, I have installed RH 7.2 on a white box
AMD K5 system w/ 3Com ethernet card, and it connects w/ no prob.

I don't know if this is a problem detecting the correct hardware during
install, a problem w/ the Tulip driver, or simply an incorrect
configuration of DHCP.  However, bfox@redhat.com reccomended I open a new
bug report against iputils. I have attached excerpts from log files which
can hopefully describe the problem in more detail than I can.  Thanks for
your help.
Comment 1 Need Real Name 2001-11-09 17:26:59 EST
Created attachment 37124 [details]
Logfile & Hardware config excerpts
Comment 2 Alan Cox 2001-12-11 11:00:37 EST
Looks like a problem with that specific tulip card eeprom/and the driver. You
may find it works if you instead use the de4x5 driver (assuming its a genuine
digital tulip chip not a clone)

Comment 3 Phil Knirsch 2002-02-24 12:14:30 EST
As Alan requested, have you tried the other driver and verified if it works with
that one?

Read ya, Phil
Comment 4 Phil Knirsch 2002-05-21 04:19:17 EDT
As i haven't received any response on this bug in 3 months i'm closing it now as
works for me (I've tried it here, and as Alan already suggested, this might
actually be a driver problem (which is my personal opinion as well) and not
necessarily iputils related).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.