Bug 55994 - Using PXE, Kernel panic: VFS can't mount root fs from initrd
Using PXE, Kernel panic: VFS can't mount root fs from initrd
Status: CLOSED DUPLICATE of bug 63945
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-09 17:57 EST by Elie Bulka
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 06:59:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elie Bulka 2001-11-09 17:57:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Using PXE to install RHL7.1, the kernel - after decompressing - complains 
about not being able to mount root fs.
The client machine has 1GB RAM.  


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have RHL7.1 based PXE server ready with Redhat supplied linux.0, 
linux.1, linux.2 (bootstrap, vmlinuz and initrd)
2. Client machine using PXE client, downloads the bootstrap (linux.0), 
which then downloads linux.1 & linux.2.
3. Linux.1 (vmlinuz) decompresses and tris to mount root fs
4. Error: "VFS: cannot open root device "" or 01:01"
          "Please append a correct "root=" boot option"
          "Kernel panic: VFS: unable to mount root fs on 01:01"
	

Actual Results:  Client machine freezes.  Cold boot is required.

Expected Results:  RHL 7.1 installation should have continued.

Additional info:
Comment 1 Elliot Lee 2002-06-21 13:22:37 EDT

*** This bug has been marked as a duplicate of 63945 ***

Note You need to log in before you can comment on or make changes to this bug.