Bug 559949 - Keystrokes appear backwards under load
Keystrokes appear backwards under load
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 08:05 EST by Emil Styrke
Modified: 2010-08-25 22:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 22:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emil Styrke 2010-01-29 08:05:10 EST
Description of problem:
When the system is under high load (i.e. when the appearance of typed characters lags behind the actual typing) the queued up characters appear in reverse order when typing in (for example) kate.

Version-Release number of selected component (if applicable):
Installed Packages
ibus.i686                                             1.2.0.20091204-2.fc12
ibus-anthy.i686                                       1.2.0.20091127-1.fc12
ibus-chewing.i686                                     1.2.0.20091211-1.fc12
ibus-gtk.i686                                         1.2.0.20091204-2.fc12
ibus-hangul.i686                                      1.2.0.20090617-2.fc12
ibus-libs.i686                                        1.2.0.20091204-2.fc12
ibus-m17n.i686                                        1.2.0.20091120-1.fc12
ibus-pinyin.noarch                                    1.2.0.20090915-1.fc12
ibus-qt.i686                                          1.2.0.20091206-2.fc12
ibus-rawcode.i686                                     1.2.0.20090703-4.fc12
kdesdk.i686                                           4.3.4-1.fc12
How reproducible:
100%

Steps to Reproduce:
1. Open kate with a large file (3.5 MiB seems to be enough on my computer)
2. Bring up the search bar (ctrl+f) and select option "highlight all"
3. Start search with a character that occurs many times in the document to trigger the highlighting. Continue typing fast enough that the typed text doesn't show up immediately in the search field.
  
Actual results:
When the search is done, the text typed while kate is busy appears in reverse order (i.e. hello comes out as "holle".)

Expected results:
Typed text comes out in the order typed.

Additional info:
I first noticed this when I enabled ibus as input methods (System -> preferences -> input method -> enable input method feature, "Use IBus (Recommended)"), which is why this is reported on the ibus package.
It is easily reproduced using kate for me (probably because of how its search function is implemented), but this happens sometimes in other apps too when the system is sluggish.
Comment 1 Peng Huang 2010-05-02 00:15:05 EDT
Does it still happen with ibus-1.3.x
Comment 2 Emil Styrke 2010-05-03 02:51:13 EDT
(In reply to comment #1)
> Does it still happen with ibus-1.3.x    

Yes, same behavior with:

ibus.i686                                             1.3.2-2.fc12
ibus-anthy.i686                                       1.2.1-1.fc12
ibus-chewing.i686                                     1.2.99.20100317-2.fc12
ibus-gtk.i686                                         1.3.2-2.fc12
ibus-hangul.i686                                      1.3.0.20100329-1.fc12
ibus-libs.i686                                        1.3.2-2.fc12
ibus-m17n.i686                                        1.3.0-1.fc12
ibus-pinyin.i686                                      1.3.3-1.fc12
ibus-pinyin-open-phrase.i686                          1.3.3-1.fc12
ibus-qt.i686                                          1.3.0-1.fc12
ibus-rawcode.i686                                     1.2.99.20100208-2.fc12
Comment 3 fujiwara 2010-06-28 03:35:10 EDT
I tried this but kate is frozen even if I disable ibus.

% head test.txt
1234567891123456789212345678931234567894123456789
1234567891123456789212345678931234567894123456789
...
...
% wc -l test.txt
73600 test.txt
% ls -l test.txt
-rw-rw-r-- 1 f f 3680000 2010-06-28 12:35 test.txt

Probably I think your text file is needed to reproduce the problem.
Comment 4 Emil Styrke 2010-06-30 04:53:58 EDT
(In reply to comment #3)
> I tried this but kate is frozen even if I disable ibus.

Yes, that's expected.  The difference would be that when kate finally unfreezes, the typed text appears backwards when using ibus and correctly when ibus is disabled.

> 
> % head test.txt
> 1234567891123456789212345678931234567894123456789
> 1234567891123456789212345678931234567894123456789
> ...
> ...
> % wc -l test.txt
> 73600 test.txt
> % ls -l test.txt
> -rw-rw-r-- 1 f f 3680000 2010-06-28 12:35 test.txt
> 
> Probably I think your text file is needed to reproduce the problem.    

Unfortunately, I no longer have access to that text file (but it happened with several different large log files), nor to the computer exhibiting the problem.
Comment 5 Fedora Admin XMLRPC Client 2010-08-02 02:09:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 fujiwara 2010-08-25 22:09:17 EDT
(In reply to comment #4)
> Unfortunately, I no longer have access to that text file (but it happened with
> several different large log files), nor to the computer exhibiting the problem.

If you could send the big file, please reopen the bug.
Currently I have no idea to reproduce your problem.

Note You need to log in before you can comment on or make changes to this bug.