Bug 559963 - libguestfs Perl programs do set locale, but still localization doesn't work
libguestfs Perl programs do set locale, but still localization doesn't work
Status: CLOSED RAWHIDE
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 08:45 EST by Richard W.M. Jones
Modified: 2010-05-18 09:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 09:44:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-01-29 08:45:51 EST
Description of problem:

$ LANG=pa virt-df --help
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "pa"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
[...]

Version-Release number of selected component (if applicable):

1.0.82

How reproducible:

Always.

Steps to Reproduce:
1. Set LANG=pa
2. Run one of the Perl tools like virt-df.
3.
  
Actual results:

Big warning message, and programs are not localized.

Expected results:

Perl programs should be localized.

Additional info:

I suspect this is actually a bug in perl-libintl, or else we're not
using it right.  'strace' shows it looking in some very strange
places for some very strange files.

See also bug 559962.
Comment 1 Richard W.M. Jones 2010-01-29 12:17:10 EST
Bug 559962 has been fixed upstream.  It is possible (but not verified)
that this will fix this bug too.
Comment 2 Richard W.M. Jones 2010-05-12 09:31:36 EDT
Two part patch posted upstream:
https://www.redhat.com/archives/libguestfs/2010-May/msg00053.html
Comment 3 Richard W.M. Jones 2010-05-18 09:43:47 EDT
Confirmed this works for me with libguestfs 1.3.13:

$ LANGUAGE=es virt-tar
virt-tar: no se han ofrecido imágenes, nombres MV, directorios o nombres de archivo
$ LANGUAGE=es virt-inspector foo
foo no es el nombre de un dominio libvirt

Note You need to log in before you can comment on or make changes to this bug.