Bug 560003 - the ever growing config file
Summary: the ever growing config file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-29 15:54 UTC by Zing
Modified: 2010-02-11 14:43 UTC (History)
2 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:43:11 UTC


Attachments (Terms of Use)

Description Zing 2010-01-29 15:54:41 UTC
Description of problem:
Every time selinux-policy is updated, my /etc/selinux/config grows by one line.

In the postinstall scriptlet is this line:

grep -q "^SETLOCALDEFS" /etc/selinux/config || echo -n "
">> /etc/selinux/config

What is the reason for this?  I don't have a "^SETLOCALDEFS" in my config file, and as a result I get these empty lines appended to my config?

Version-Release number of selected component (if applicable):
selinux-policy-3.6.32-69.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. upgrade selinux-policy 
  
Actual results:
empty line appended to /etc/selinux/config

Expected results:
no empty line appended to /etc/selinux/config

Comment 1 Daniel Walsh 2010-01-29 22:12:18 UTC
Yes that is a bug.

Miroslav, can you remove those lines.

Comment 2 Miroslav Grepl 2010-02-01 15:00:03 UTC
Fixed in selinux-policy-3.6.32-80.fc12

Comment 3 Fedora Update System 2010-02-03 23:19:39 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 4 Fedora Update System 2010-02-05 01:45:43 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 5 Fedora Update System 2010-02-11 14:38:36 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.