Bug 56002 - noauto+RAID broken
Summary: noauto+RAID broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-10 05:28 UTC by Mike Bird
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 19:55:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Bird 2001-11-10 05:28:08 UTC
Description of Problem: Change in rc.sysinit in RH7.2 skips starting
/dev/mdN devices marked noauto in fstab, but fsck still checks them
... and bombs
Version-Release number of selected component (if applicable): initscriipts-6.40-1


How Reproducible:


Steps to Reproduce:
1. Create a RAID (happens to be RAID-5 here but I don't think it matteers)
2. mke2fs the RAID, add it to /etc/fstab and mark it noauto
3. reboot

Actual Results: rc.sysinit skips starting that /dev/mdN because it is
noauto, but fsck tries it anyway and bombs

Expected Results: Previous to RH7.2, the RAID start was not skipped
and the server rebooted and I didn't have to drive to the next county
to fix it  :-O
Additional Information:

Comment 1 Bill Nottingham 2005-04-05 19:55:23 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

With mdadm, this isn't as much of an issue in this case; previously, the RAID
startup code did change post-7.2, so the issue may have been fixed in the meantime.


Note You need to log in before you can comment on or make changes to this bug.