Bug 56005 - RFE: provide specfile(5) documentation
RFE: provide specfile(5) documentation
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-10 06:44 EST by Edward J. Huff
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:48:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix problem in man page -- where do spec files come from? (1.50 KB, patch)
2001-11-10 06:48 EST, Edward J. Huff
no flags Details | Diff

  None (edit)
Description Edward J. Huff 2001-11-10 06:44:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i586)

Description of problem:
The man page should explain how to obtain the spec file
in order to unpack the sources without recompiling and 
installing the package.  Also 'rathen' should be 'rather'.

Version-Release number of selected component (if applicable):
rpm-4.0.3-1.03.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. man rpm
2. /rathen
3. /spec *file
	

Additional info:

patchfile attached.
Comment 1 Edward J. Huff 2001-11-10 06:48:28 EST
Created attachment 37181 [details]
Fix problem in man page -- where do spec files come from?
Comment 2 Jeff Johnson 2001-11-20 11:28:32 EST
Thanks for the patch. However, since rpm build modes
are now resident in /usr/bin/rpmbuild, and documented
in rpmbuild(8), the patch should go there.

Furthermore, and more importantly, spec files really need
to be documented in specfile(5). So I'm gonna change this
into a RFE for specfile(5).
Comment 3 Bill Nottingham 2005-09-29 17:48:31 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.