Bug 56008 - klipper can't start actions
klipper can't start actions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-10 09:25 EST by Chris Ricker
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-27 12:48:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-11-10 09:25:32 EST
klipper (KDE clipboard thingie) has a nice feature where it can apply
actions to text on the clipboard:  open URLs in a web browser, display
images with kview, etc.

Unfortunately, at least for Mozilla URL action, klipper can't actually
*start* mozilla.  If mozilla is already running on the system, then klipper
will work; it will spawn an additional mozilla window, and display the URL
in the window.  If mozilla is not running at all on the system, however,
then klipper will refuse to display URLs using mozilla.
Comment 1 Bernhard Rosenkraenzer 2001-11-27 12:18:41 EST
Verified. Didn't notice (why would anyone use Mozilla if you can have 
Konqueror? ;) )
Comment 2 Bernhard Rosenkraenzer 2001-11-27 12:21:28 EST
Ok, this is caused by mozilla refusing to create a new window when invoked with

mozilla -remote 'openURL(http://slashdot.org/, new-window)'

...

Comment 3 Bernhard Rosenkraenzer 2001-11-27 12:31:50 EST
The fix isn't simple:
You'd have to do something along the lines of

if [ -n "`/sbin/pidof mozilla`" ]; then
	mozilla -remote "openURL(%s,new-window)"
else
	mozilla %s
fi

which in turn won't be expanded correctly because %s doesn't expand twice in a 
printf string.

Experimenting with workarounds; the real fix would break compatibility with 
klipperrc from earlier versions.
Comment 4 Chris Ricker 2001-11-27 12:48:07 EST
Well, *I* use mozilla 'cause konqueror sucks ;-)

Seriously, this same problem probably applies to netscape as well (haven't
checked, as I don't use netscape now that mozilla works with all the sites I
need).  The basic problem with mozilla is that it's doing the -remote stuff,
which is a protocol inherited from netscape, and the way -remote works is that
it passes commands to an already running browser (netscape used to have a white
paper on it, though I have no idea where to find it these days).  I'm not
currently at a machine where I can check, though.
Comment 5 Chris Ricker 2002-08-30 14:44:42 EDT
This actually works for me with the latest rawhide kdebase and mozilla!  Thanks!

Note You need to log in before you can comment on or make changes to this bug.