Bug 56012 - minor y2k bug
Summary: minor y2k bug
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: mirror   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-10 17:58 UTC by Ion Badulescu
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:51:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for mirror.pl (608 bytes, patch)
2001-11-13 18:28 UTC, Matt Selsky
no flags Details | Diff
fix for dateconv.pl (392 bytes, patch)
2001-11-13 18:30 UTC, Matt Selsky
no flags Details | Diff

Description Ion Badulescu 2001-11-10 17:58:11 UTC
Description of Problem:
in the emails it sends after mirroring a package, mirror says something like:

Mirrored redhat-5.2-updates (updates.redhat.com:/5.2/en/os -> /misc/mirror/os/linux/redhat/updates/5.2) RedHat 5.2 updates @  8 Nov 101 10:28

Notice year 101... :-) Oh well, another standard perl script bug...

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1.  mirror a package
2.  read email
3. 

Actual Results:


Expected Results:


Additional Information:
to fix: edit /usr/lib/mirror/dateconv.pl, go to second line from the bottom, replace
      return sprintf( "%2d $months[ $mon + 1 ] %2d %02d:%02d", $mday, $year, $hour, $min );
with
      return sprintf( "%2d $months[ $mon + 1 ] %4d %02d:%02d", $mday, $year + 1900, $hour, $min );

Comment 1 Matt Selsky 2001-11-13 18:27:52 UTC
There is some other small changes necessary.  I tried mailing
mirror-people@icparc.ic.ac.uk (the devel list for mirror.pl) but the list
doesn't seem to be working.

Comment 2 Matt Selsky 2001-11-13 18:28:52 UTC
Created attachment 37422 [details]
fix for mirror.pl

Comment 3 Matt Selsky 2001-11-13 18:30:02 UTC
Created attachment 37423 [details]
fix for dateconv.pl

Comment 4 Bernhard Rosenkraenzer 2002-01-18 17:10:10 UTC
Since powertools has been discontinued, the official fix is the removal of the
package (sorry).


Note You need to log in before you can comment on or make changes to this bug.