Bug 56021 - installer converts ext2 to ext3 befor checking drive space
installer converts ext2 to ext3 befor checking drive space
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-10 19:21 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 16:24:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-10 19:21:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
installer converts ext2 to ext3 befor checking drive space. If there is not
enough drive space for the upgrade the upgrade fails and leaves you with a
system that will not boot!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. take RH6.2 system  with limited space
2. begin install 
3. install converts file system befor checking packages
4. there is not enough room for the upgrade	
5. upgrade fails 
6. system will not boot!

Additional info:
Comment 1 Michael Fulbright 2002-01-16 16:24:56 EST
How much space was free initially? Afterwards?
Comment 2 Need Real Name 2002-01-17 11:29:31 EST
a few hundred megs befor and after because the install never happens. It simply
does a conversion then checks to see if there is enough drive space to do the
upgrade. When it finds that there is not enough drive space to install the new
redhat it lets you know. when you reboot the old kernel has a hartatack when it
sees the ext3 file system.
Comment 3 Jeremy Katz 2002-04-10 18:05:14 EDT
This is related to the fact that the rpmFreeSpace check takes a *really* long
time to do.  Will revisit for a future release
Comment 4 Jeremy Katz 2003-02-17 16:24:53 EST
Current ext2 code is able to mount ext3 without problems as long as the
filesystem is cleanly unmounted (and current e2fsprogs can handle the journal
replay).   Moving things around significantly complicates the logic.

Note You need to log in before you can comment on or make changes to this bug.