Bug 56026 - mkbootdisk fails on recent "smp" and "enterprise" kernels
mkbootdisk fails on recent "smp" and "enterprise" kernels
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-10 22:32 EST by Dmitri A. Sergatskov
Modified: 2007-04-18 12:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-20 00:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2001-11-10 22:32:33 EST
Description of Problem:

Recent "smp" and "enterprise" kernels (plus respective initrd's) are too
big to fit on floppy. As a result mkbootdisk fails. (This is also
applies to "install" for rh7.2 which uses mkbootdisk to make a bootfloppy.)
Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
 
1.find an i686 with a SCSI or two (or whatever makes initrd bigger)
2.become root, install "enterprise" kernel if it is not
	installed already
3.mkinitrd --device /dev/fd0 2.4.9-13enterprise

	
Actual Results:
It fails during initrd creation with  "No space left on the device"
error.

Expected Results:
It works with no error messages.

Additional Information:

	Just FYI:
[root@cholla boot]# ls -l /boot/initrd-2.4.9-13enterprise.img 
-rw-r--r--    1 root     root       455871 Nov 10 17:47
/boot/initrd-2.4.9-13enterprise.img

[root@cholla boot]# ls -l /boot/vmlinuz-2.4.9-13enterprise    
-rw-r--r--    1 root     root      1044432 Oct 30 17:53
/boot/vmlinuz-2.4.9-13enterprise
Comment 1 Matthew Saltzman 2001-12-08 21:18:10 EST
This also happens with the standard 2.4.9-13 kernel (at least the Athlon version).
Comment 2 Stephen Moehle 2002-03-02 16:49:04 EST
I find that 2.4.9-13 for UP athlon is the last kernel for which I can make a
boot disk.  Both -21 and -31 fail.  Maybe it is time for a mkbootcd command.
Comment 3 Simon Matter 2002-03-05 10:14:42 EST
I'm using the SGI XFS installer based on either RedHat 7.1 or RedHat 7.2. With
the XFS enabled kernel it was never possible to create a bootdisk because of the
XFS code which enlarged the kernel too much. It seems that 'mainstream' RedHat
kernels suffer the same problem now. I have created patched RPMs of mkbootdisk
which allows to create overformatted bootdisks and I have not found any pc until
now which could not boot such a disk.
Updated mkbootdisk RPMs are here:

http://home.datacomm.ch/simix/XFS/rh-7.2/

Create bootdisk as usual, but use a different device:
mkbootdisk --device /dev/fd0u1722 2.4.9-31enterprise

Would be nice to see the patch integrated into the next RedHat release.
Comment 4 Need Real Name 2002-04-20 00:35:37 EDT
It doesnt work for 2.4.9-31 on a intel system either.  However a grub boot disk
can hold the current size of the vmlinuz image (952 kb).   For automated boot you
would have make the appropriate entries into menu file.  There of course is the 
rescue mode on the iso image cdroms.  Of course this boots the image of the iso, 
but it can help you fix a boot problem.
Maybe someone could write a utility to create boot cd rom from your current 
kernel.


Comment 5 Erik Troan 2002-06-03 15:13:28 EDT
"out of space" isn't a bug in mkbootdisk, though it is a limitation that's
becoming more and more important.
Comment 6 Steen Jensen 2003-12-30 04:09:14 EST
Hi !!

"Out of space" isn't a bug in mkbootdisk, well is then a limitation 
in glibc? This is incredible annoying, I am running Red Hat Linux 
Enterprise 2.1 AS 2.4.9-e.27 SMP and I was able to create the 
bootdisk when I ran at the 2.4.9-e.3 SMP levl, no I am left outside 
the door.

Red Hat Support tells me that this bug has been seen in Red Hat 9 as 
well, but I am running  Red Hat Linux Enterprise 2.1 AS 2.4.9-e.27 so 
I really don't care, I have purchased a product and I expect it to 
work.

If my server craches how do I then get access the a kernel having my 
detected SCSI devices discovered?

Now I have been told to play with the mkbootdisk --iso --
device /root/boot.img command and I still keep asking myself, why on 
earth shall I start to use time on this.

Have anyone of you played with the iso-stuff?

I have a Red Hat Linux Enterprise 3.0 AS running next to me and there 
it works fine, but I really need to get something going on the Red 
Hat Linux Enterprise 2.1 AS level 

//Steen

Note You need to log in before you can comment on or make changes to this bug.