Bug 560277 - Python import fontforge "SystemError: Missing library: libfontforge"
Summary: Python import fontforge "SystemError: Missing library: libfontforge"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-30 19:05 UTC by Tony Nelson
Modified: 2010-04-10 10:15 UTC (History)
3 users (show)

Fixed In Version: fontforge-20090622-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-09 04:25:01 UTC
Type: ---


Attachments (Terms of Use)

Description Tony Nelson 2010-01-30 19:05:37 UTC
Description of problem:
$ python
Python 2.6.2 (r262:71600, Aug 21 2009, 12:22:21) 
[GCC 4.4.1 20090818 (Red Hat 4.4.1-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import fontforge
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
SystemError: Missing library: libfontforge
>>> 

Fontforge's Python module expects a libfontforge.so file, but fontforge only provides libfontforge.so.1 and libfontforge.so.1.0.0.  Creating a symlink libfontforge.so -> libfontforge.so.1 works.  Either fontforge should include the symlink or the fontforge Python module should use the specific symlink.

Version-Release number of selected component (if applicable):
fontforge-20090622-2.fc12.i686

How reproducible:
Every time.

Steps to Reproduce:
1. python
2. import fontforge
3.
  
Actual results:
Traceback

Expected results:
Successful import

Additional info:

Comment 1 Kevin Fenzi 2010-01-31 23:00:12 UTC
I fixed this in devel/rawhide a while ago, but didn't push a f12 build. 

I'll have to look and see if doing so will cause problems.
We don't want to get in the situation where an upgrade to fontforge causes fonts to no longer build...

Comment 2 Kevin Fenzi 2010-03-21 05:38:30 UTC
Sorry for the delay here. 

Turns out there was a typo in my patch. It didn't ever work, but no one told me so, and my test machine was messed up in a way that made it work. ;) 

Please test the f13/f12 builds and add karma if they work for you. 

Thanks very much for the report!

Comment 3 Fedora Update System 2010-03-21 05:39:41 UTC
fontforge-20090923-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fontforge-20090923-3.fc13

Comment 4 Fedora Update System 2010-03-21 05:54:49 UTC
fontforge-20090622-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fontforge-20090622-3.fc12

Comment 5 Tony Nelson 2010-03-21 21:48:25 UTC
"python -c 'import fontforge'" works now without the symlink workaround, tested fontforge-20090622-3.fc12 on i686.

The Karma comment stuff is too hard to use, so I won't.

Comment 6 Kevin Fenzi 2010-03-21 23:11:49 UTC
No worries. Thanks for testing.

Comment 7 Fedora Update System 2010-03-23 01:57:01 UTC
fontforge-20090923-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fontforge'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fontforge-20090923-3.fc13

Comment 8 Fedora Update System 2010-03-23 02:19:27 UTC
fontforge-20090622-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fontforge'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fontforge-20090622-3.fc12

Comment 9 Fedora Update System 2010-04-09 04:24:57 UTC
fontforge-20090923-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-04-10 10:14:59 UTC
fontforge-20090622-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.