Bug 560287 - [abrt] crash in Miro-2.5.4-1.fc12
Summary: [abrt] crash in Miro-2.5.4-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cedcbc4b
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-30 19:43 UTC by jefer_m
Modified: 2010-09-15 05:51 UTC (History)
3 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:03:44 UTC


Attachments (Terms of Use)
File: backtrace (1.37 KB, text/plain)
2010-01-30 19:43 UTC, jefer_m
no flags Details

Description jefer_m 2010-01-30 19:43:40 UTC
abrt 1.0.4 detected a crash.

architecture: x86_64
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: Miro-2.5.4-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TBcedcbc4b video.py:436:seek_to:TypeError: unsupported operand type(s) for *: 'NoneType' and 'float'

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/customcontrols.py", line 98, in do_button_press_event
    self.move_slider_to_mouse(event.x, event.y)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/customcontrols.py", line 125, in move_slider_to_mouse
    wrappermap.wrapper(self).emit('moved', self.get_value())
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 155, in emit
    if callback.invoke(self, args):
  File "/usr/lib64/python2.6/site-packages/miro/signals.py", line 76, in invoke
    return self.func(obj, *(args + self.extra_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/videobox.py", line 370, in on_slider_moved
    app.playback_manager.seek_to(new_time)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/playback.py", line 327, in seek_to
    self.player.seek_to(progress)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/video.py", line 436, in seek_to
    time = self.get_total_playback_time() * position
TypeError: unsupported operand type(s) for *: 'NoneType' and 'float'

Local variables in innermost frame:
position: 0.61155913978494625
self: <miro.frontends.widgets.gtk.video.VideoPlayer object at 0x7f4484245750>

Comment 1 jefer_m 2010-01-30 19:43:43 UTC
Created attachment 387767 [details]
File: backtrace

Comment 2 Alex Lancaster 2010-01-31 19:22:44 UTC
Can you reliably reproduce this?  Please describe the exact conditions that
lead to the crash.  Crash reports without detailed information describing
exactly how to reproduce the bug are almost impossible to fix.

Also were you attempting "acoustic fingerprinting" (i.e. "Scan" tracks) and do you have picard-freeworld from RPM Fusion installed?  See:

http://musicbrainz.org/doc/Picard_FAQ#I_am_using_Fedora.2C_why_doesn.27t_acoustic_fingerprinting_work.3F

Comment 3 Alex Lancaster 2010-01-31 19:29:22 UTC
(In reply to comment #2)

> Also were you attempting "acoustic fingerprinting" (i.e. "Scan" tracks) and do
> you have picard-freeworld from RPM Fusion installed?  See:
> 
> http://musicbrainz.org/doc/Picard_FAQ#I_am_using_Fedora.2C_why_doesn.27t_acoustic_fingerprinting_work.3F


Please ignore this last section, it was for the wrong package...

Comment 4 jefer_m 2010-02-02 23:57:18 UTC
I can't reproduce this, sorry. 

Jeferson

Comment 5 Ben Dean-Kawamura 2010-05-05 19:48:27 UTC
I couldn't reproduce this one, but I'm pretty sure how to fix it.  I made
http://bugzilla.pculture.org/show_bug.cgi?id=13308 in our bugtracker system and just checked in a changeset that fixes it.

Comment 6 Fedora Update System 2010-08-29 17:19:05 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 7 Fedora Update System 2010-08-29 17:26:11 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 8 Fedora Update System 2010-08-29 17:30:17 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 9 Fedora Update System 2010-08-30 19:40:50 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 10 Fedora Update System 2010-09-14 05:01:42 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-15 05:33:40 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-09-15 05:48:48 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.