Bug 56030 - xslt-config --cflags output includes -I/usr/include
Summary: xslt-config --cflags output includes -I/usr/include
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libxslt   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-11 12:29 UTC by franz.sirl-kernel
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-11 14:17:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description franz.sirl-kernel 2001-11-11 12:29:48 UTC
Description of Problem:
xslt-config --cflags output includes -I/usr/include, which is a system 
include dir and according to the GCC documentation shouldn't be specified 
on a GCC command line.
But since a lot of configure scripts (eg. KDE2, kdelibs/kdoctools) depend 
on the output of xslt-config --cflags, this is unavoidable and will 
potentially cause compilation problems. Especially g++ >= 3 is affected by 
this.


Version-Release number of selected component (if applicable):
1.0.1-3

How Reproducible:
Everytime

Steps to Reproduce:
1. run 'xslt-config --cflags' in a shell
2. 
3. 

Actual Results:
[fsirl@linuxpc1:~]$ xslt-config --cflags
-I/usr/include -I/usr/include/libxml


Expected Results:
[fsirl@linuxpc1:~]$ xslt-config --cflags
-I/usr/include/libxml


Additional Information:

Comment 1 Daniel Veillard 2001-11-11 13:18:13 UTC
I will try to get this fixed in the next release. However
I don't "support" compiling with a gcc compiler on the 3.00+ branch
yet. A number of bugs where exhibited with 3.00 and 3.01 miscompiling
libxml2, I was told that new version fixed it but I didn't checked
it and it's not part of my development environment yet.

Daniel

Comment 2 franz.sirl-kernel 2001-11-11 13:59:23 UTC
Fine with me, I'm just making sure it's not forgotten :-). And the gcc3 libxml2 
bug got fixed in 3.0.2, Jakub checked in a fix.

BTW, in 1.0.6-1/rawhide, who is supposed to include xsltconfig.h? xslt.h would 
need it to define LIBXSLT_PUBLIC and the documentation doesn't mention the user 
has to include it before xslt.h?



Comment 3 Daniel Veillard 2001-11-11 14:17:49 UTC
3.0.2: yep I heard it was fixed.
concerning 3.0.6 include bug, I need to push libxml2-2.4.10
and libxslt-1.0.7 which should fix it,

 thanks for the reminder,

Daniel

Comment 4 Daniel Veillard 2001-12-11 19:58:22 UTC
Should be fixed in RawHide now,

Daniel


Note You need to log in before you can comment on or make changes to this bug.