Bug 560319 - [abrt] crash in xine-ui-0.99.5-16.fc12
[abrt] crash in xine-ui-0.99.5-16.fc12
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xine-ui (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
abrt_hash:be041bab86bd329da6a8ff19f40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-30 18:54 EST by Stuart D Gathman
Modified: 2010-03-11 16:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-11 16:29:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (27.49 KB, text/plain)
2010-01-30 18:54 EST, Stuart D Gathman
no flags Details

  None (edit)
Description Stuart D Gathman 2010-01-30 18:54:23 EST
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: xine
comment: Awoke from suspend, inserted DVD, ran xine from menu.  No sound, and check.  Rebooted, and it worked fine.
component: xine-ui
executable: /usr/bin/xine
kernel: 2.6.31.12-174.2.3.fc12.i686
package: xine-ui-0.99.5-16.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. 
2. 
3.
Comment 1 Stuart D Gathman 2010-01-30 18:54:24 EST
Created attachment 387790 [details]
File: backtrace
Comment 2 Susi Lehtola 2010-01-31 05:25:12 EST
Update to newest xine and try if you can reproduce this.
Comment 3 Stuart D Gathman 2010-01-31 21:10:59 EST
The laptop I reported this on was already completely up to date.  It is my daughters, and not available at this moment.  However, I tried the same sequence on my desktop (also completely up to date).  Suspended with DVD in drive.  Woke up, ran xine.  No more sound.  Xine didn't abort, but reported an error - at the same moment as a kerneloops.  messages shows lots of "Jan 31 21:04:05 rafael kernel: ALSA sound/core/pcm_lib.c:181: BUG: pcmC0D0p:0, pos = 0x7c04000, buffer size = 0x4000, period size = 0x4000" and the kerneloops is in the middle of them.  Rebooting is required to restore sound. 

My naive guess is that this has to do with sound drivers interacting badly with suspend, more that a bug in xine.  (Different sound cards on the laptop vs desktop BTW.)  However, this seems to happen when the first sound after coming back from suspend is xine trying to play a DVD.

I will try more experiments as time permits.
Comment 4 Stuart D Gathman 2010-01-31 21:21:19 EST
Just to confirm, xine works fine after rebooting.  Suspend works better than it ever has in Fedora 12, but is still somewhat fragile.  Hmmm, I wonder what happens if I suspend in the *middle* of playing a DVD with xine ... BWA HA HA HA!
Comment 5 Susi Lehtola 2010-02-01 02:29:17 EST
(In reply to comment #3)
> The laptop I reported this on was already completely up to date.

That's right - the new version is still in updates-testing..

But yes, this really does sound like a general problem with sound. Do you get any else audio playback?
Comment 6 Stuart D Gathman 2010-02-01 11:28:32 EST
All sound in all applications is broken when xine is the first sound after returning from suspend.  So xine is tickling some kind of driver bug.  Will try updates-testing version soon.  Oh, one other nit: both the desktop and laptop have Intel video.  The laptop uses the default kernel mode set, the desktop uses the "nomodeset" kernel option (otherwise, no xvideo).  None of this seems to be xine's fault.  But if it tickles a driver bug, it is worth pursuing - and suspending in the middle of DVD playback *is* a good torture test for suspend.  I really will try it.
Comment 7 Susi Lehtola 2010-02-10 02:37:07 EST
What if you don't run xine at all, you just suspend and return and try to play back audio?

Note You need to log in before you can comment on or make changes to this bug.