Bug 560334 - FSError: filesystem has not been created
Summary: FSError: filesystem has not been created
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:c0740a2e0d99d3d30...
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-01-31 02:08 UTC by Clyde E. Kunkel
Modified: 2013-01-10 05:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-05 16:41:37 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (920.81 KB, text/plain)
2010-01-31 02:09 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2010-01-31 02:08:59 UTC
The following was filed automatically by anaconda:
anaconda 13.23 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 586, in mount
    raise FSError("filesystem has not been created")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 834, in setup
    return self.mount(**kwargs)
  File "/usr/lib/anaconda/storage/devices.py", line 1604, in setup
    self.slave.format.setup()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 312, in execute
    self.device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 670, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 287, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1308, in nextClicked
    self.anaconda.dispatch.gotoNext()
FSError: filesystem has not been created

Comment 1 Clyde E. Kunkel 2010-01-31 02:09:07 UTC
Created attachment 387799 [details]
Attached traceback automatically from anaconda.

Comment 2 Clyde E. Kunkel 2010-01-31 02:29:48 UTC
Reused an existing LV for / and existing ext4 part for /boot, selected format ext4 for both and when clicked OK to format, boom.

Comment 3 Clyde E. Kunkel 2010-02-05 04:18:37 UTC
Tried again with anaconda 13.25 and error did not occur.

Comment 4 Adam Williamson 2010-02-05 16:41:37 UTC
closing, then (dlehman also tried to reproduce and couldn't). reopen if it reoccurs!


Note You need to log in before you can comment on or make changes to this bug.