Bug 56034 - VERY BAD: scsi disks accessed thru pcmcia controllers are not properly unmounted at shutdown time
VERY BAD: scsi disks accessed thru pcmcia controllers are not properly unmoun...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-11 09:51 EST by Alfredo Ferrari
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 22:33:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Ferrari 2001-11-11 09:51:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13.1 i686)

Description of problem:
All scsi partitions mounted thru my scsi pcmcia controllers (apa1460 or
apa1480a, the latest using aic7xxx_mod) are not properly unmounted at
shutdown. Actually the system stops the pcmcia services WITHOUT unmounting
the scsi partitions and then hangs with a kernel OOPS... when trying to
unmount all filesystem later.

This is a very bad bug which is there since the "new" kernel based pcmcia
package (yenta_socket) and was never there with the previous pcmcia
modules. Also 7.1 is affected as well. You can easily crash the system at
shutdown time and trash the scsi disks of course.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount a scsi partition thru a pcmcia scsi controller using aic7xxx_mod (I
used an Adaptec apa1480a)
2.shutdown the machine without manually unmounting the partition
3.look at the resulting kernel oops
	


Actual Results:  the machine got a kernel panic

Expected Results:  an orderly done shutdown with proper unmounting of the
relevant partitions BEFORE shutting down the pcmcia services

Additional info:

I have RH7.2 with all updates installed on a Latitude C800 with an Adapted
apa1480a adapter and one scsi hd, one fuijtsu MO drive and one Yamaha CR/W
write attached to the scsi chain. The problem appears on both the hd and
the MO, whichever is mounted, and it was there as well on RH7.1 (I just
upgraded and discovered it was not fixed)
Comment 1 Alfredo Ferrari 2002-05-28 11:40:36 EDT
It is nice to see how nasty bugs are solved quickly... of course still there in
valhalla
Comment 2 Dave Jones 2004-10-25 22:33:23 EDT
going through old unclosed bugs..
Did this ever get resolved? Does this problem still exist
in our current Fedora/RHEL products ?

Please reopen if this is still a problem.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.